Stake pool topology

Hello, I just created a stake pool but I think it’s not running properly.
On gliveview, my BP has 1 incoming and 1 outgoing connection. P2P disabled
On my relay, I have 1 incoming and 23 outgoing connection. P2P disabled

On my grafana dashboard, in Tx processed, I have no data (Mempool bytes + Mempoo transactions : no data)

When I look on Cexplorer, it says my relay is offline, but I don’t understand why because the relay node is running.

My guess is that I messed up my iptables for port forwarding.

Can someone see what could be wrong ?

Hi. You have no incoming connections to your relay because no other pools has your relay data in their topology files. Until P2P is used, you can make use of the Topology Updater to broadcast your relay info to other stake pools. That’s what most of us are doing.


In case you are already using topology updater and you still have 1 incoming connection, then it’s a misconfiguration issue. In this case check the logs and let us know what’s inside, and also give us more info how you set it up.

Thank you! I’ll set up again the topology updater, I think it’s because I forgot to type -4 on the curl command. I’ll try that and keep this post updated.
In the code, there is this line that I don’t really understand:

CNODE_HOSTNAME=“CHANGE ME” # optional. must resolve to the IP you are requesting from

Should I change the “Change me”? If yes, to what ? A name like the name of my stake pool or, my public ip adress or I let it like that ?

It’s the IP of the relay you are running the script from.

Regarding the firewall. If using ufw, type sudo ufw status numbered and see if you allow incoming traffic to your node’s port.

Ok, will fix that. But, sorry for the stupid question, it’s the private IP right?

I am not using ufw, I have a setup with qubeos and I write the port forwarding rules manually in the start up scripts when I start sys-net and sys-firewall (if you know how qubes works)

It’s the public IP of your relay. You can also use the relay address that resolves to that same IP. From the variable naming it implies they are expecting the relay hostname including the domain but the IP will work as well. At least I have it configured with the IP.

Problem solved. My problem was that the port was not open properly.

After running some scripts to forward properly until my appVM (it’s a QubeOS specific procedure) everything worked fine!

As said many time on similar problems, you can check if your port is open with websites like Open Port Check Tool - Test Port Forwarding on Your Router
Don’t forget that your service must be running in order to check the port.