Trying to install Stake Pool Node

I’m trying to set up a Stake Pool on a VM running Ubuntu. I’ve been following the instructions in the Stake Pool Course.
I entered the command: cabal configure --with-compiler=ghc-8.10.7 which ran for a very long time.

It got to step [ 14 of 189 ] and ended with the following error:

[ 14 of 189] Compiling PlutusCore.Pretty.Readable ( plutus-core/src/PlutusCore/Pretty/Readable.hs, dist/build/PlutusCore/Pretty/Readable.o, dist/build/PlutusCore/Pretty/Readable.dyn_o )
: cannot open shared object file: No such file or directory
cabal: Failed to build plutus-core- (which is required by
test:cardano-node-test from cardano-node-1.35.3, exe:cardano-node from
cardano-node-1.35.3 and others).

Now, I have been playing with computers since the 1970’s but really never picked up much linux, so I really don’t even know where to begin to troubleshoot this.

Any help would be appreciated.

perhaps the guide is not updated… so better to use other guides…
There is coincashew guide or cntools (more friendly with user … using scripts) cannot open shared object file: No such file or directory

for this error u will need to install libsecp256k1

U can fund the steps here


Thanks Alex,

I’ve bookmarked the site. I’ll probably wait until Monday to see if I can get it up and running.

Will the steps I’ve already done in the Stake Pool Course cause any problems, or can I just overwrite what’s there?

hmm, it depends which guide did u use

I used the one in the Stake Pool Course at

It seemed like the proper one to follow. :slight_smile:

then try to install libsecp256kp1 manually and continue with the guide

Ok, I went back to the directions for downloading and compiling. There was a command - git checkout $(curl -s | jq -r .tag_name) that was longer than the window showing it. I may not have copied the entire string before.

This time I copied the entire string and continued on through the process. I got a LOT fewer WARNINGs this time, most of which were about various things being experimental. This time there wasn’t an abort. It looks like I got all the way through.

$ cardano-cli --version
cardano-cli 1.35.3 - linux-x86_64 - ghc-8.10
git rev ea6d78c775d0f70dde979b52de022db749a2cc32
$ cardano-node --version
cardano-node 1.35.3 - linux-x86_64 - ghc-8.10
git rev ea6d78c775d0f70dde979b52de022db749a2cc32

Thanks for the help!

1 Like

Learning…learning…always learning…

Ok, I got my node to run by copying the following command:
cardano-node run \

This of course doesn’t have any of the information required for Paths and IP, but the Node runs.

The YT video by Carlos talks about making the node information easier to read by changing a couple of things in the mainnet-config.json file. I’ve used Config files for 30 years, so I’m comfortable changing something inside.

Changed “TraceBlockFetchDecisions”: to true
He also changed “ViewMode”: to “LiveView”
My config didn’t have a ViewMode, so I inserted it between the two lines it showed on his file, making sure to use correct syntax. I’m assuming position of the command doesn’t matter, but I wanted to be safe.
I saved the config file, then modified the run commands so that the Paths are correct.

Because I’m running this at home, I have a Dynamic IP. My VPN gives me a static IP address, along with Port Forwarding, so I used that IP address and made sure the VPN was running.

The error I got is:
cardano-node: Network.Socket.bind: unsupported operation (Cannot assign requested address)

I was guessing the VPN is interfering with the node. I didn’t have the VPN running when the node worked by typing in cardano-node run\

Just for shitsandgiggles I also tried it without the VPN running, using the Dynamic IP address I currently have.
That gave me the same error.

Try with

Ok, that works but I’m confused.

The way Carlos explained it in the video, it sounded like the IP address had to be the IP address I’m using.

Apparently “ViewMode” doesn’t work. At least not as described in the video. I’m not too worried about it, I have a working Node. will listen on all interfaces
install or use gliveview
PS: the guide is to old I believe