Trying to send a transaction I get this error

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutputTooSmallUTxO [(Addr Mainnet (KeyHashObj (KeyHash “e2e9465e534e3b719c72066a4efd31828bc8e084f266c1f26062a0b2”)) (StakeRefBase (KeyHashObj (KeyHash “9424e78f73134ac397f2f9a71ce2b5b37f733880fb33df08bef0a3ca”))),Value 821123 (fromList ),SNothing)])))])

You are trying to send an amount of less than 1 ADA to one of your --tx-outs. That’s not allowed. Every output has to be at least 1 ADA, more if other tokens are contained.

I was using this to calculate the fee which came back at 178877
Which is the 3 ADA total I have - 821123 in the error I’m guessing

fee=$(cardano-cli transaction calculate-min-fee \
    --tx-body-file tx.tmp \
    --tx-in-count ${txcnt} \
    --tx-out-count 1 \
    --mainnet \
    --witness-count 2 \
    --byron-witness-count 0 \
    --protocol-params-file params.json | awk '{ print $1 }')
echo fee: $fee

Hmm, 178 877 + 821 123 = 1 000 000. So, it seems you set the output to be exactly 1 ADA and then subtract the fee from that after calculating it.

I have no idea

what is the available balance of your address?

I transferred 3 ADA and its coming up as 3000000

Isn’t that fee missing a 0 off the end?. I thought thee fee was suppose to be 2 ADA

the fee must be no less than the calculation… if you will want to set fee 2ADA it’s up to u but it/s to much… try this steps

for a simple transaction the fee should be ~0,2 ADA
if the wallet has 3ADA you can set the fee to 0,25 ADA to be sure is covered and the transfer amount 2,75 ADA

I’m registering a staking node, I thought it said it costs 2 ADA

to register the pool will cost 500 ADA + transaction fee (you will receive 500 ADA back as rewards when you will retire the pool)
2 ADA is to register a stake address (to delegate) + transaction fee

there are 2 different task

cardano-cli transaction build-raw \
    ${tx_in} \
    --tx-out $(cat payment.addr)+${txOut} \
    --invalid-hereafter $(( ${currentSlot} + 10000)) \
    --fee ${fee} \
    --certificate-file stake.cert \
    --out-file tx.raw

I was using this from CoinCashew

If you are trying to register a stake address, then 3 ADA are not enough.

2 ADA will go into deposit and additionally there is a transaction fee. (Those are two different things.)

But at least 1 ADA has to go into the transaction output.

So, you’ll need 2 ADA deposit + 1 ADA transaction output + transaction fee, which together is around 3.2 ADA.

Yes it’s registering stake address…ok I’ll add more ADA thanks.
That fee looks like 0.17 ADA to me

Yep, 0.2 was just a rough estimate.

It should be 2.0 or 1.7 shouldn’t it?
10x more so my fee is wrong?

then this sentence is wrong, perhaps you are registering a staking address?

No, the transaction fees are not that high.

When registering a stake address (or a pool), there is a deposit, but that’s something different than the transaction fee.

Added another 10 ADA and still get same error