Wallet does not run at mac osx 10.13.2


#1

hi
i downloaded latest version of wallet and install it on mac in first run every things is ok and it downloads block and run wallet , i maked new wallet but after sometime i want to check my balance but wallet start make trouble it runs one time every 5 time i run it, 4 other try to run do notthing i have to force shutdown app and run it again and again to have chance to app run correctly
but today have not chance so i decide to remove app and download and install again but after that …
now i don’t enable do run to download blocks and other activity(it does not even open a window just sit in process )
do you have a solution ?


#2

I do not know if we have tested on the newest version. I have not upgraded to high sierra at all. Try the daedaluswallet faq.


#3

I noticed that on High Sierra, when you launch Daedalus, it starts normally after syncing the latest blocks.

Then if you close it and re-click on it to relaunch it, 100% of the time it doesn’t launch, it just keeps bouncing on your dock, and you get the “Application not responding” error, and you have to force quit the app, and restart your computer to solve it.
Maybe it’s just me… but I am running the latest Daedalus version on the latest OS High Sierra 10.13.2


#4

ah, steam does this on my computer, very frustrating


#5

Hi @arshiay,

I’m running Daedalus 1.0.3619 on OSX 10.13.2 without issue. Wish I could tell you what I was doing differently, but I haven’t encountered any problems.


#6

My wallet does not “connect to network”. Same macOS High Sierra 10.13. I tried every possible solution, open port 8090, check outbound connections to IP:3000, sync system clock, but nothing works.

Node log:

[node.worker.subscription:NOTICE:ThreadId 564] [2018-01-09 16:58:20 UTC] subscriptionWorker: lost connection to NodeId 13.115.81.99:3000:0 Exceptional (TransportError ConnectTimeout "Timed out")
[node.worker.subscription:NOTICE:ThreadId 564] [2018-01-09 16:58:20 UTC] subscriptionWorker: subscribing to NodeId 13.250.72.221:3000:0
[node:WARNING:ThreadId 2332] [2018-01-09 16:58:25 UTC] self: sending MsgRequestBlockHeaders Nothing to NodeId 13.228.226.191:3000:0 failed with TransportError ConnectTimeout "Timed out" :: SomeException
[node:DEBUG:ThreadId 2332] [2018-01-09 16:58:25 UTC] self: sent MsgRequestBlockHeaders Nothing to NodeId 13.228.226.191:3000:0
[node.worker.security:ERROR:ThreadId 554] [2018-01-09 16:58:25 UTC] Security workerTransportError ConnectTimeout "Timed out"

#7

I had the same issue for long time. I just downloaded hide.me VPN app for Mac, registered for a free account, turned on VPN and Daedalus connected to the network and now I am trying to restore my wallet from the cardano blockchain.


#8

I think force closing the Daedalus wallet causes a lock file to get stuck… Try this on a Mac when the wallet is stuck. It worked for me on Mac OSX 10.13.2.

  1. Close Daedalus.
  2. Open a terminal.
  3. type in each line below and press
    cd ~/Library/Application\ Support/Daedalus/Wallet-1.0
    rm open.lock
  4. Open Daedalus

Step 3 directory is actually:
cd ~/Library/Application Support/Daedalus/Wallet-1.0

Step 4 when you open Daedalus the open.lock file will be re-created.

But you have to put the backslash due the space in Application Support.