Yoroi says Cardano app in Ledger isn't up to date, but it is

When I try to connect Yoroi app on iOS to my Ledger Nano X, it says I need to update my Cardano ADA app on my Ledger to version 2.2.1. I’m on version 3.0.0. How can I get my wallet connected?

1 Like

do u see the install buton available for cardano app?

Install the Cardano ADA app on your Ledger device

  1. Open Ledger Live and navigate to the Manager tab.
  2. Connect and unlock your Ledger device .
  3. If asked, allow the manager on your Ledger device.
  4. Search for the Cardano ADA app in the app catalog.
  5. Click the Install button to install the app on your Ledger device.
  • Your Ledger device displays Processing.
  • Ledger Live displays Installed.

Also the yoroi app for mobile is updated?

1 Like

Like I said, it’s already installed. I can open the app. It says “waiting for commands” on my ledger, but the iOS app says I need to update it to version 2.2.1, not to install it. The problem is that the Cardano ADA app on the ledger is version 3.0.0, and the Yoroi wallet wants it to “update” down to 2.2.1

But maybe u will need to update the yoroi app not the cardano app from ledger

Same here.

I have Nano X (2.0.0) with Cardano ADA app 3.0.0, with latest versions of browser extension and iOS app. And have connection issues either to PC or phone.

During the connection process in iOS app, it says:

  • Requested operation failed. Cardano ADA app installed in your device is not up-to-date. Required version 2.2.1

And browser extension says

  • Something unexpected happened. Please retry.
1 Like

It looks there is an issue after the last update since many users have this problem… try to connect the ledger on adalite.io and perform transactions from there

With the release of version 2.4.1 instead of 3.0.0, the problem was solved

1 Like

yes, solved with Cardano ADA 3.0.0 (NEW 2.4.1) update