Yoroi Shelley Mainnet - ADA not available after wallet restore

Hi. I had some ADA on my ITN Yoroi wallet and got some rewards too during testnet phase. I tried to restore the wallet on Yoroi Shelley Mainnet. The balance is showing as zero. I used Byron Era selection and restored using 15 word pneumonic.

I tried to restore the wallet using ITN Yoroi extension again to check if my balance is there. The balance and rewards fields are not showing up and I see a spinner in it’s place and getting message that it’s not able to connect to the internet.

Does anyone face similar issues and see zero balance after restoring to Yoroi Mainnet wallet? Is my ADA safe?

What was the source of your ITN funds? You would have created ITN wallet and migrated funds off a snapshot, and you need those mnemonics to access Byron funds.

(As regards not being able to see ITN extension - the support for ITN ended a couple of months ago)

1 Like

Thanks a lot Priyank.

It makes sense now. At the time of snapshot, my funds were in Daedalus. As I was not able to delegate from there, I transferred those funds to Yoroi and started delegating.

So, for me to go to Shelley Mainnet, do I need to install Daedalus and restore those funds? I see only 12 word pneumonics for my Byron Daedalus wallet and I see only 15 and 24 phrase restores on Yoroi Shelley Mainnet.

Again thanks for the reply and clarifying the things.

Yes, You can use Daedalus or Yoroi to restore those funds.
If using Yoroi, two steps:

  1. Create Shelley Wallet (save new seed), check here
  2. Claim/Transfer funds , check here

ITN Rewards can be claied later using Claim/Transfer funds in upcoming version, but this should allow you to consolidate your funds into a shelley wallet.

1 Like

Thanks a lot Priyank.

It worked. I was able to restore my Byron Daedalus wallet to Shelley Yoroi Mainnet wallet using the two steps you mentioned.

1 Like