Issue restoring ada from Yoroi Wallet into Rewards test-net

After restoring my Yoroi wallet for delegation into Daedalus Rewards test-net wallet. I see 0 balance, Is this a known issue? I did the balance check and I know my funds wore captured when the snapshot took place. Any help will be appreciated.


1 Like

This worked for me :

“First create a new Yoroi wallet on testnet, save the 15 words phrase and then select restore legacy wallet and put in your real wallet phrase. After the restore process is complete you’ll be asked to transfer your ADA from the snapshot balance wallet to your newly created wallet” Lucian Boboc on Twitter

I tried following this step. I keep getting cannot transfer funds error? Any ideas why?
This happens when I try to “Wallet Upgrade”. If I skip this step my wallet gets restored, but I have 0 balance.

In Yoroi :
1.- Don’t upgrade the wallet, just create a new one with new 15 words phrase.
2.- Once inside the new wallet you will have 0 funds, press the “Daedalus to Yoroi” icon and select the “TRANSFER FUNDS FROM ANOTHER WALLET” tab.
3.- Press the “LEGACY 15-WORD MNEMONIC” button and use your original 15 wallet phrase and follow the steps.

I hope it helps.

1 Like

i tried many times, after the balance showed try to transfer funds, but

Unable to transfer from another wallet
Unknown error.

Unable to transfer from another wallet
An error occurred, please try again later.

Unable to transfer from another wallet
Error received from server while getting UTxOs.

i hope someone can help. thanks

You need to make sure you are using the Chrome or Firefox Yoroi Testnet Extension. If you are using a Yoroi wallet you cannot use the Daedalus testnet.

im using yoroi testnet already, its different extension from yoroi wallet extension. is there anything else? need help here.

You need to explain more clearly exactly what you’re trying to do.

Friends i try to transfer my ada on shelley testnet wallet snapshot before 29 Nov into my new shelley testnet wallet that I’ve just created. I tried using transfer funds from another wallet. Using legacy 15 word mnemonic until the balance check is ok and the balance is valid. But the transfer fund is never done. The error information are unable to transfer from another wallet, an error occured please try again later, error received from server while getting UTx0s.
I dont know why? I tried many time, using different pc and notebook, using different network. Can anyone help?

Im using yoroi staking testnet on mozilla firefox.

To use the testnet you don’t transfer, you restore. That’s the reason for the snapshot, so the wallet already exists on the testnet you just need to restore it, to work with it.


I tried to restore first, but the ada balance is 0.000 (invalid ada balance, not equal to snapshot balance) so then i’ve created new wallet to tranfer ada using transfer funds from another wallet (from my legacy 15 words snapshot wallet). Anyone can help?

Hey thanks again for your help. I followed your steps, but now I am getting “Unable to transfer funds.” error. I am using Chrome Testnet Extension to do this.

Just thought I’d add I’m getting the same, its a mix of “unable to transfer funds” after its showed me the correct balance from snapshot or an error screen after it looks like it might be doing something (the first wallet i restored after a few attempts but this one is being an arse)

I just created a new Wallet, went to Transfer Fund from Another Wallet (behind the Deadelus to Yorio icon) then Legacy 15 word mnemonic and after showing no transactions or balance for about 20-25 minutes it has updated, correct balance & all. Remember to look after your newly create wallet mnemonic

So after trying to restore my wallet multiple times I have managed to make it work. If you are still having this issue. Just keep trying and eventually it will work. good luck.

Don’t worry is not working for me anymore … I see the Pending Circle of Doom in Yoroi 2.2.2

Restore wallet or create new wallet and then using transfer funds from another wallet sir?

Alright, I will explain what I did step by step. This is assuming you have downloaded and installed Yoroi Staking Testnet for Chrome or Firefox (SHELLEY-TESTNET)

  1. From the home screen click on the “create wallet” option.
  2. Follow the steps to generate a new test-net wallet. Create a 15 digit word, password etc.
  3. Next (Once the wallet is created) on the top right corner you will see the “Daedalus to Yoroi” icon. Click on that.
  4. Finally, type your 15-WORD MNEMONIC.
  5. If it all goes well you should see your snapshot Ada in your wallet.

Note: This may not work the first time so, keep doing this until you see your funds in your new wallet. I had to try multiple times to get this working. Hope this helps someone.

i have almost the same problem. i tried several things. Also the steps “create new wallet…”
I have always a 0 in my balance.
What is very strange. The question: Transfer Funds… shows me a different address than the wallet address. Is this normal?
In the testnet explore i can see a transaction to the “Transfer Funds address”. How can i have access to this address?

This worked for me sir, many thanks!!!