Yoroi Trezor "Change address staking rights..." sending problem

Please create a support ticket at: https://iohk.zendesk.com/hc/en-us
(Looks like Yoroi is no longer an option there. Go here: Yoroi - Light Wallet for Cardano and click “Contact us” in the bottom then “Contact us” again in the chatbox, there you’ll get a form to enter).

They need to know that this is affecting multiple users. I got a quick response from support but it was only a suggestion of errors that could be on my end (wrong Trezor, wrong passphrase, etc).

Then let us know if they give you a solution.

So I’m a bit embarrassed but hopefully this helps others.

I’m quite new to all of this and it was my first time setting up a hardware wallet. Trezor asks you to setup a pin but then at some point it asked me to choose a password for a wallet and I thought it was asking for my PIN again so I typed that.

The error message i was getting was basically, wrong password. Now if it said “wrong password” I think I would have figured out my error more quickly, but it says something about staking so I thought it might have been about staking.

Anyway, using the correct password (which ended up being my device PIN due to my mistake) worked for me.

Did anyone find a solution to this?

from what I understood, when you have this error it means that the trezor has another wallet than the old one from yoroi… so try to connect the trezor on adalite.io … do you see 0 balance? if yes check if you:

  • upgraded the trezor and this issue occurred after the upgrade
  • check inside trezor settings if the passphrase was activated (try to deactivate) or maybe you use a different passphrase when you created the wallet
  • perhaps you have another trezor wallet or perhaps you restored using the seed words, etc
  • anyway, you will need to find the the right wallet on trezor (where the ADAs were sent)

When I restore the wallet using my passphrase on adalite I also get a 0 balance wallet. I have tried everything with this Trezor, using my passphrase, disabling passphrase, typing the passphrase slightly wrong, and so on.

I guess I can try installing old firmware on the Trezor and see if that helps, but I don’t see why it would.

Check if probably u save the passphrase on browser

Thanks but I have only ever entered the passphrase on my physical Trezor device, never using keyboard/browser.

Yoroi support is non-existent!!
Total silence. I thought ADA was better than this…!!!
I deleted the app and reinstalled with pass phrase so I should have the latest version. No difference. I can’t get my ADA!

Hi, this is clearly a Trezor problem,
I have exactly the same problem.

It resets a different wallet so balance 0…

  • I don’t use passphrase and never used
  • I’ve never used another hard wallet

I have the wallet image when I created it using Trezor and the wallet image that trezor restores (they are different)

In Adalite it was to load because it imports keys from all accounts (when there is more)

Do you mean that you can restore the correct account in Adalite, but not in Yoroi?

hello unfortunately not,
he doesn’t carry it in any wallet,
he always carries a different wallet than before
obs: I never used more than 1 account on trezor, I never used a long password and I always used the same PIN

I believe you and I are having the same problem…
I believe there was a bug in creating the wallet using trezor on yoroi…
I saw your story and it’s just like mine.

I believe it’s a bug in the creation with yoroi because when I carry the trezor in any other wallet (adalite, daedalus, CC…) it always carries the same wallet with a balance of 0.

My wallet was this d453277b32c6232e2455e3c29074347b745880bf0d85b66f565ce40b
and now it loads only this 8cfcf5cd081d4ad6e61822e44a202c1270de27c0758a3ccbae206f2b

Yoroi is a joke. I’ve started leaving reports on their twitter feed. I suggest everyone else with problems and no support does the same. https://twitter.com/YoroiWallet/status/1450492243652063235

hey friends,
discovered trezor explorer
https://trezor.github.io/connect-explorer/#/

you can see all possible addresses for all networks your trezor may have

on the cardano network in get public key > export multiple public key, you press the button get multiple public keys, that way you can see the possible wallet by trezor.
NOTE > if you change the last number of the BIP44 PATH to 1 for example, you can see a possible new wallet number in ACCOUNT 2.

IN NO WAY DO YOU FIND MY OLD PORTFOLIO, THE ERROR REALLY SEEMS TO HAVE BEEN FROM YOROI WHEN CREATED THE PORTFOLIO AND SEEKED THE WRONG HASH FROM TREZOR

Can you guys please make support tickets where you link this thread and also my other thread: Yoroi and Trezor problems They need to know that several people have this problem and that it’s not because of the users’ own mistakes.

Go to the bottom and click “Contact us” then “Contact us” again and fill in the form.

I don’t think it will make any difference. I’ve started leaving notices on their Twitter account.

https://twitter.com/YoroiWallet/status/1450492243652063235

Copy paste from my other thread:

Thanks to some chat with Trezor support I found a solution (and in the end it was my own mistake): Problem with Yoroi/ADA and Trezor Model T - Third party wallets - Trezor Forum

Basically, when first creating the wallet I was an inexperienced user and when the Trezor connect window asked for my passphrase, I thought it was asking for me to create a password so I entered a password. Result is that I created a new hidden wallet on my Trezor with that password as passphrase, without knowing it. (Then I didn’t touch my wallet for several months and forgot the details of what I had done). When I use that password as passphrase the correct wallet is restored.

So for anyone else with the issue, try remembering if you entered a password when importing your wallet into Yoroi, and use that as a passphrase. Or try all your common passwords as passphrase (if you re-use passwords, which you shouldn’t). Best case that would restore the correct hidden wallet (that you didn’t know you had created).