Yoroi and Trezor problems

Hello. I have created a Trezor wallet (Shelley) using the Yoroi extension in Brave, sent ADA to the wallet and delegated them. But I have two very serious problems that I need help with, and from searching around it seems many other users also have similar problems when using Yoroi and Trezor Model T.

1. I cannot restore my wallet in another browser or another service.

I created the wallet using a Trezor account with a passphrase. I did not create a standard Yoroi wallet and was not given a seed phrase. I am 100% sure of this and that I have used the correct passphrase every time I try to restore the wallet or interact with Yoroi. In the account it says “Shelley - Trezor wallet”.

  • If I try restoring the wallet using Yoroi on another browser or computer, it creates an empty wallet.
  • If I try restoring the wallet using Adalite it creates an empty wallet.
  • I have tried with and without passphrase on both Yoroi and Adalite. I have also tried disabling the passphrase. But it still creates empty wallets.

The only way I can see my wallet with funds in it is in Yoroi on the specific Brave browser where I created it. I assume it is stored locally somehow.

I can see the account address on cardanoscan with all funds correct and delegated.

I have not tried removing the wallet from my current Yoroi extension as that seems risky and pointless. I want to move the funds away from Yoroi to a new wallet ASAP and currently this is the only way I can actually see my wallet.

2. I cannot perform any action in the account but get this error message on my Trezor: "Change address staking rights do not match the current account"

I have tried claiming rewards and sending ADA, and get the same error message. Three pages on the Trezor:

  • Change address staking rights do not match the current account
  • Staking key hash: [numbers and letters]
  • Change amount [numbers] ADA

The change amount seems random but is generally above 2000 and not at all the amount I tried sending or claiming.

I have tried without passphrase also and get the same error message.

Summary: I have created a Trezor wallet in Yoroi and delegated funds. Now I cannot restore my wallet or perform any account action at all, so my funds are stuck! And I don’t think I am the only one with similar issues. I see several threads about restored wallets coming up empty and problems with Trezor specifically:

Here is the sending issue with the error message:

Here someone can’t restore their Trezor wallet on Adalite but gets an empty account:

Please help! Thank you.

Did u ever restore the trezor using the 24 seed words? Also it’s the same original trezor wallet or did u changed it?

I created the wallet using a Trezor account with a passphrase.

Are u sure u are using the right passphrase?

I have not restored the Trezor wallet itself as it is working just fine. I have only tried restoring my ADA/Yoroi address in the Yoroi extension and on Adalite, using the Trezor and passphrase.

Yes, I am 100% sure it’s the correct passphrase.

Did u upgraded meantime?

Upgrade what? I did upgrade the firmware on the Trezor. I don’t think I have updated Yoroi.

Yeah, asking if u upgraded the firmware after u created the wallet and moved the funds on trezor

Yes. I have upgraded the Trezor firmware a few times since I created the wallet and received and delegated my ADA. Could that be an issue?

Should not be if u said u was able to delegate after the update, do u have an another trezor device? The wallet must be hidden …but this happens when u use differents passphrases

No I didn’t delegate after any firmware upgrade. I received ADA and delegated them several months ago using the same firmware. After that I didn’t use the Yoroi wallet at all, and did upgrade the Trezor firmware a few times. But I don’t know exactly when the problem started. Only recently did I try to restore the wallet on another PC/browser like I said, and it didn’t work.

  1. Created Trezor wallet on Yoroi using passphrase.
  2. Received and delegated ADA.
  3. Upgraded Trezor firmware a few times.
  4. Tried restoring the ADA wallet on Yoroi/Adalite but got empty accounts. Also tried sending/claiming rewards from the Yoroi where my wallet is, but get the error message.

No it’s the same Trezor that I have been using all along.

I don’t know what to say… u can try to restore the trezor using the seed words … but it’s your decision… also u can try to downgrade the firmware… or u can contact yoroi team

Some one fixed…

This happened to me as well just now. I figured out what the problem was although i don’t know if you have the same problem. My issue was that i used the “standard wallet” when first using yoroi, but never after that. months later i forgot all about the standard wallet. Go to trezor Suite and go to the standard wallet. when it asks you for the passphrase in Yoroi, don’t type anything on the Trezor (just hit “ENTER” on the PC, which is what you do for non passphrase (non hidden) trezor accounts). That worked for me, hope it does for you

I wrote to support, let’s see what they say. If I try something else I’ll write an update here. (Disabling passphrase I have already tried and it didn’t work on Yoroi or Adalite). Thank you.

I suspect by “passphrase” you mean you are putting your recovery phrase (24 word mnemonic phrase / seed phrase) into Yoroi. This is known to not work due to a bug in how Trezor & Ledger create Cardano private keys vs. the official Cardano standard used by Daedalus & Yoroi:

Ledger has a similar but different bug, so Trezor-generated Cardano wallets don’t show the same addresses on Ledger or vice versa.

Due to this bug, the only way to restore a Trezor-created Cardano wallet is on another Trezor. There is a feature request to add “Trezor recovery phrase” support to Daedalus/Yoroi but it hasn’t been done yet.

Ideally you should never be putting your recovery phrase into a software wallet like Yoroi anyway, because this completely defeats the purpose of having a hardware wallet like the Trezor. You should just connect the Trezor to Yoroi as a hardware wallet to keep your keys safe.

Note that “passphrase” specifically refers to something else, a special “25th word” (not really) password that can be added on top of your 12-24 word recovery phrase for extra security. Just like with the recovery phrase, you should only enter the passphrase on the hardware wallet itself, never in a software wallet.

No that is not the case here. I am talking about a Trezor passphrase. I mean that I try to recover the account using the Trezor, and the Trezor wallet that I used to create the account has a passphrase, the “25th word” just as you say. I am not asked to enter any seed phrase anywhere. It just redirects to the Trezor webpage where I allow it to share the public key, and enter the passphrase. This is the same whether I try to restore the account, or perform an action (send or claim rewards, for example).

(And yes, I only enter the passphrase on the Trezor hardware itself, not in any software wallet).

HI!
I have EXACTLY the same problem.

Your step-by-step description is the same as mine.

My ADA’s are blocked because the yoroi wallet says my trezor isn’t the same!!! An “unexpected error” appeared when I was going to transfer my ADA’s.

Sorry for my “English”… I’m from Brazil.

By chance you discovered something new to solve your problem… I’m thinking the cause is the same.

Please, if you know anything… post the solution here. I am desperate.

Thanks

B.

I have this exact problem as well, but when I try to just hit ENTER in Yoroi it tells me it is a required field and won’t let me proceed to restore the wallet

Hi,

No solution yet unfortunately.

Support tells me that if I created the wallet using the same Trezor and same passphrase, then I should get the same wallet when I restore it in Yoroi or adalite. But when I do that I get an address with nothing in it. (In other words they are saying it’s not Yoroi’s fault, but rather me who is messing up somewhere). But I am very sure I am using the same Trezor and passphrase and I am very careful when I type it in. (I have never typed the wrong passphrase on my Trezor and clicked the green check box thing to proceed, so me having done it this one time only and not remember it would be so unlikely).

Please write to support on the Yoroi website and link this thread to show them several people are having this issue!

I don’t know my replay can help but I have same problem to you
i try a lot thing to fix but all is my user error when create wallet first time I create passphrase but i forgot i create that one word in Trezor
So when connect to another PC without passphrase it’s show empty wallet and yes if I close option passphrase in trezor it’s not work too because my old wallet use with my own passphrase
Now I can fix because I random a lot pass use in normal life and have luck one is my passphrase to use with trezor all ada comeback again

I am glad that worked for you Dit. For me I am sure I have the right passphrase and it still doesn’t work unfortunately.

Oi amigo conseguiu resolver seu problema? tambem estou com o mesmo problema… Obrigado