Yoroi missing tokens with Trezor

I tried the hidden address on Trezor this afternoon, but can move the token to anywhere.


Anyone can help?


Hey @a13519

Im not 100% sure but i dont really understand whats the issue here. What would you expect to see on the screenshot you shared?


Sorry I missed it. I can’t delegate nor send tokens. If I do I will get this:

There is no error message about incorrect password or keys.

Yeah Yoroi does currently have some issues.

You might want to use adalite.io in meantime.

I tried adalite.io, but I can’t see any balance in adalite, only in Yoroi.

Did you connect your hardware wallet with adalite.io? You dont have to restore your wallet with your seedphrase.

I connected my Trezor with adalite, but I see an account with balance 0.

Do you see any outgoing transactions?

I tried public account and hidden account on Trezor both are empty, when I use Yoroi to sign the chrome does ask me to confirm on Trezor hidden mode and validate but throw the Error received from server while sending transaction

no outcome transaction

Did u ever restored/replaced the trezor? Check to trezor settings if u have enabled the passphrase, if yes try to disable and connect again the trezor on adalite.io

The PIN is disabled, and I still can not see the balance.

It’s scary that I can see balance in Yoroi, and I tried to export the public key from Yoroi in the screen shot attached, I search the addresshttps://cardanoscan.io/address/3a5fc4ac6f8eb8c7475373c838238791c4b1e09b128fc86ffa4a65a84c98e6834e1c114202874130b83c6c0ecc199edb84174b1caff9180352c20483ec6afdc9 in https://cardanoscan.io/ I can’t see any balance. That means when I send the Yoroi capture the transaction correctly and reserve the balance, but the backend server of Yoroi DIDNOT send token correctly to the above address, please help to take a look.


I had this discussion many times with different people… at the end they discovered that the funds were on another device so:

  • did u ever restored the trezor?
  • did u used another trezor?
  • check for the passphrase not for the PIN
  • did u ever restored the trezor? No, no PIN change no restoration
  • did u used another trezor? No, only one Trezor but a Ledger, and the token was transferred from Ledger to Trezor hidden a/c
  • check for the passphrase not for the PIN, I only have PIN, what passphrase you refer to?

This is not an address, go to yoroi - receive section, copy one address and check in cardanoscan.io

It’s interesting that under my destination wallet there are 2 addresses one of them has balance:

The tokens were transferred to the address generated by Yoroi and the transaction and adascan say so, I suspect Yoroi returned an address through GUI is not the one derived from private key, that is why we can’t find any balance from my Trezor, but the network and Yoroi transaction recorded the journals, this is a scary hole, that make the legitimate process has unpredictable result and it definitely could result a bit loss, please investigate.