Cant stake after changing wallet

Okay I am a big noob here.

I bought a small amount of ADA for the first time and wanted to start staking. I Got the Yoroi wallet and started staking. Happy as Larry

I then shortly found out I can stake from my Trezor T and decided to send the ADA over and start staking from there. No problem. I just want to stake from my Trezor T and not from the standard wallet.

But, I’m a noob and an idiot, I didn’t remove the stake before I transferred the wallet. Now with my Trezor T Yoroi wallet I get the error message: ‘Change address staking rights do not match the current account’

Even if I try to stake to the same pool with the funds showing in my account I still get this message. It just wont let me delegate it anywhere. Any help would be much appreciated!

Hi @ProperBarz,

This is the place for questions. No worries :grinning_face_with_smiling_eyes:

Each wallet can stake independently of other wallets. So if you got a non-hardware wallet and stake some ada with that and then create an additional hardware wallet, you can also stake with that one to another pool. So this should not be your problem.

Are you able to send some small amount of ada from your trezor wallet to somewhere else? I want to make sure that part is working and that maybe your trezor has a passphrase you have to type correctly.

Otherwise you might try adalite or use yoroi with another browser.

did u restored the Trezor meantime?
another guy fixed by : “Thanks god I found out where was the problem. I just had to deactived the passphrase in Trezor settings.”

@ADA4Good If I try to send from Yoroi wallet to somewhere it comes up with ‘Something unexpected happened. Please retry.’

If I retry, it doesn’t work.

Even if I disable the passphrase its the same problem. Same error

Try to reinstall the browser extension or try another browser.

@ADA4Good I reinstalled on the browser but I don’t have any ADA now, everything has gone. I have tried resyncing it but still doesn’t do anything

You got a Trezor Model T right?
When you reinstall the browser extension (try another browser if it doesnt work) it asks you what kind of wallet you want to connect. Did you select “hardware wallet” - “Trezor” - “cardano” - “shelly”?
If yes, then it will ask you to connect your trezor and enter pin. Then it will export your public keys and after that you will see your wallet with your ada.
If your trezor also has a passphrase, it will ask you to enter it. This is not the same as the pin! you need to type the correct one otherwise you will get an empty wallet.

So did you do all this?

Yes Trezor T, Hardware wallet, Trezor, cardano, shelly, export your keys.

It asks me to enter a passphrase, but I’ve either forgot this or I haven’t made one. Regardless I am not seeing any ada. So it sounds like I do not know my passphrase. Does it mean one of the phrases from my seed? Or did I make a specific phrase?

I my other crypto on my trezor wallet, just nothing on the yoroi

yes, it is related to passphrase, I understand there is a video on youtube which shows you how to bypass the passphrase

@ craigpeter can u share it?

OK, clear. Let’s go through the lingo:

  • PIN: is de numeric code you always have to type on your trezor to make transactions and other import things

  • Seed Phrase: this is the 24 words you can use to recover your wallet if you forget your PIN or lose your trezor

  • PassPhrase: this is optional. When you create your trezor wallet you can opt to add this. This goes on top of your PIN. each passphrase you type will get access to another wallet. But if the passphrase is not the right one you will get a empty wallet. See below.

you might want to check this movie showing this too:
(153) ACSC Lesson 2: Setting Up Passphrase Protection on a Trezor - YouTube

and this blog from trezor:
Recovery Seed, PIN and Passphrase | by SatoshiLabs | Trezor Blog

You can disable your passphrase in your wallet I believe

Update: I won’t know how to disable a passphrase if you don’t have it though.

Okay, so I believe I have lost my passphrase, which Is unrecoverable. My own fault for not understanding that the passphrase is more important than the seed!

Good job It was only a tiny amount!

I didn’t think I used a passphrase, but If I disable the pass on my trezor there is still no ada on my yoroi. So I obviously used a passphrase, doh! I have an address of the wallet as I sent the money too it, but I have no way of recovering it!

You can bypass that step, just wait for the @craigpeter to respond/share the video :wink:

It had the same issue

Would be cool if there was! A man can hope!

But meantime… did u tried to restore the trezor using the seed words?

@Alexd1985 I dont use the passphrase but from what I understand it acts like the 25th word of your seed. So I would be very curious how that other person could bypass his passphrase and how just your seed words would help get your ada back…

My trezor has my crypto. But it does not store ada

It is only my Yoroi wallet that has no ada. I transfered my funds from my yoroi wallet to a yoroi trezor wallet and now I cannot find my ada.

I hope that makes sense

I do not need to recover my trezor only find my trezor yoroi wallet

Understand but ur ada wallet now is hidden on the trezor somehow and it will show u 0 ADA to the balance

Yes but I cant find the passphrase for that specific trezor yoroi account within my trezor… so it will be hidden untill I rememeber it.