Cannot Deregister / Unstake ADA on Yoroi

Hi,

I’ve been trying to degister / unstake my ADA from a stake pool but Yoroi keeps giving me the following message:

’Something unexpected happened. Please retry.'

I’m not sure what is up? Can anyone help please?

Thank you!

Hi,

Browser or mobile wallet?

Cheers,

Hey,

This is on the browser thanks.

Cheers!

That is a lousy error message. How could you possibly understand what went wrong? I wonder wha the errror handling code looks like and I sure hope it can be improved. It could at the very least tell the name of the routine and at what line things went bad. This is something you can do in c++.

1 Like

Can u restore the wallet on yoroi mobile version or on your browser on adalite.io and try again?

Cheers,

I’m using a Trezor if that makes any difference?

Nope, connect it on adalite.io

I’ve connected it to ADA Lite but I’ve already staked all my ADA on Yoroi so I can’t really see much on it.

I’ve also tried using a different browser using my Yoroi extention but I couldn’t connect it at all.

on yoroi… do u see trezor word near shelley wallet name? Are u sure the funds are secured by trezor? Because u should see on adalite.io same wallet as on yoroi… :thinking:

On Yoroi, it says ‘Trezor wallet’ at the top of the page. I had to use my Trezor when I moved my ADA to Yoroi and and stake my ADA.

I just sucessfully deregistered my girlfriend’s ADA on Yoroi. I taught her how to store and stake her crypto and it seems I can’t even help myself. Haha.

I appreciate your replies though Alex, thanks!

You are welcome…

so do u see standard wallet or trezor wallet?

image

When u restored the trezor on adalite… it’s the same wallet number as on yoroi? Or it’s another new/empty wallet ? Also do u see any transactions history?

I see ‘Trezor wallet’ thanks.

Great… and do u see same wallet number on yoroi and adalite.io?

I just saw your question at the end sorry. Where do I see the wallet number on Adalite?

hmm, I think right after you connect the trezor… if not copy on cardanoscan.io one address from yoroi and adalite … check if both belong to the same wallet (should have same stake address)

Hey Alex, I hope you’re well!

I can’t see anything on my AdaLite once I’ve connected it with my Trezor. I’ve tried my gf’s one who has the exact same setup as mine (I set it up) and her balance is the same on both Yoroi and AdaLite so I understand what it is supposed to look like now.

I bought a tiny bit of ADA and transferred it to my Trezor wallet and saw the new updated balance on Yoroi. It might have been wishful thinking but I was hoping this would change something or it might have been something to do with not having enough ADA for gas fees. However, nothing has changed and I still see the same error message.

I’ve seen some recent news that Yoroi has some sort of bug. I’ve contacted them and they are yet to reply. I’ll also message in the Trezor forum to see if it’s something to do with Trezor.

Other than that, do you think there are any other solutions? At least my ADA is safe right?

Many thanks for your help once again!

do you used passphrases when you created the trezor wallet?

Cheers,

No I don’t.

Maybe u used another trezor passphrase? can u check on trezor sertings how is set the passphrase?

I’ve checked all my wallets and I don’t have a passphrase for my ADA.

I believe someone from Yoroi has gotten back to me.

support@emurgohelpdesk.zendesk.com

Does the email sound correct? They’re asking me for my logs.

Thanks.