Yoroi Trezor "Change address staking rights..." sending problem

So I’m trying to send ADA on my Yoroi wallet linked to a Trezor Model T.

It was working fine but now it’s not.

When I try to confirm on the Trezor the following message pops up:

“Change address staking rights do not match the current account”. Followed by a staking key hash and weirdly a “Change amount” from 5 ADA to 34 ADA.

Even if I accept this change the transaction fails.

So my ADA are stuck on the Yoroi wallet (visible) but I can’t send them.

I’ve restored the Trezor with it’s seed but it doesn’t help.

I’ve contacted Yoroi support, no idea when or if they will respond.

I’ve seen that this topic has come up before but so far none of the suggestions have worked for me.

Reposting here as I put the original request in the wrong category, thanks.

Just for info here is the original posting:

Hi there,

Go to Trezor advance settings and disable passphrase. This worked for me.

ut 8. 6. 2021 o 22:13 PAUL S PREECE via Cardano Forum <cardano@discoursemail.com> napísal(a):

Yes I noticed it worked for you.

Unfortunately I’m not using the passphrase option in Trezor so there is nothing to disable.

Did you updated Trezor? If so, this problem occured after that?

No I did not update Trezor.

Everything was working fine, I changed nothing, then boom, it no longer works.

I just sent some Cardano to the Trezor Shelley wallet and it got there ok but I can’t send anything out just like in your original posting.

What about spending password? Are you requested for it where you are trying to send ADA?

The spending password is only for the standard shelley wallet? I have both a standard Yoroi and a Trezor Yoroi linked wallet.

The standard wallet works fine and asks for the spending password. It can send and receive.

The Yoroi Trezor wallet does not ask for a password as it communicates directly with the Trezor. It asks to export the public key which I give permission for.

I can receive on the Trezor shelley wallet but I cannot send out as the transaction fails as happened on your posting. “Change address staking rights do not match the current account”.

I am not so familiar with Trezor - is it initiated with a recovery phrase? Is it compatible with Yoroi recovery phrase? Have you tried to recover this wallet in Yoroi?

Trezor is a standalone device and has its own recovery seed. There is no seed associated with the Yoroi wallet when using the Trezor device.

I’m not going to remove the existing Yoroi Trezor wallet as it is the only proof of where my coins are. People say if your coins are on the blockchain then they are safe but what if you cannot access them because your hardware no longer allows you to?

I’m beginning to think the Yoroi wallet is a piece of crap that has somehow loaded a different wallet onto my Trezor because the public keys are different. The new public key is not the same as the old key where the Yoroi wallet still shows the correct balance. So now my Trezor has a different public key and hence is not recognised by the old Yoroi wallet. Way to go.

The fact that Yoroi support do not reply does not help either. I wish I’d never loaded them onto Yoroi, they would have been safer at Coinbase.

It’s not about yoroi… otherwise u should be able to see the funds on adalite.io

The problem is trezor… u restored it and now u have other public keys and another wallet… what if before to restore u had a password and u restored without it?

1 Like

yes - Yoroi only shows information based on what Trezor is providing… there is no any writing method from Yoroi to Trezor. Hardware wallets are read-only devices - can be modified only via the device… if you have different public key - it is only possible if you provided a different recovery phase… or Trezor is a “piece of crap”

The public keys and addresses are not needed to send currencies, only to receive. How many private keys have you got ? You can have a same recovery seed that will give two different keys when using two different derivation paths. Or you could have created a Yoroi wallet and in this case you would have two of them. How did you link the Trezor ?

I’ll explain the steps from the beginning.

  1. I installed the Yoroi extension onto Chrome.
  2. First I created a standard Yoroi wallet without the Trezor. I sent ADA from Coinbase to the wallet as a test. All good.
  3. Then I created another Yoroi wallet using the Trezor. I send ADA from Coinbase direct to this wallet. All good.
  4. I then sent ADA from the Yoroi-Trezor wallet to the standard wallet as a test. All good, no problems.
  5. Unplugged the Trezor usb and put it in the safe.
  6. 2 weeks later I need to send some ADA. Take out the Trezor and plug it into the Yoroi-Trezor wallet. Check the balance in the wallet, all good.
  7. Try to send ADA using the Trezor but now it will not let me send.
  8. Error messages in Trezor say "“Change address staking rights do not match the current account”.
  9. After trying various remedies I reseeded the Trezor with the only 12 word mnemonic I have. This restored the Trezor and all other coins are good. Go back to resend on Yoroi, same problem, transaction fails.
  10. The Yoroi-Trezor wallet still has the correct balance and transaction history but when connected to the Trezor it will not let me send, only receive.

And that’s it. At no point did I do anything daft, I’ve been buying crypto since 2013, I’m not an expert but I’m not a noob either. This is the first time I’ve had a problem with a wallet.

I feel you (raph_cardano) might be on the right lines though. I read that the Yoroi wallet can handle different accounts. It seems to be some error in reading the wrong account. When I plug it into adalite.io the balance says zero but what if there is another key inside the Trezor from the original Yoroi-Trezor wallet that I created and is now hidden/overlaid for some reason? I don’t know how this stuff works but I think you’re on the right track. I still have the original Yoroi-Trezor wallet that was created 2 weeks ago and it’s all correct. Maybe the keys for this are still in the Trezor but how to access them or switch accounts.

As to your question I cannot find the private key info for the Trezor. Apparently you only have the mnemonic and this automatically generates the keys but you can’t see them.

I only created the one Trezor-Yoroi wallet and it’s the one I still have with all transaction history present and correct. I can access it, receive on it but I can’t send…

hi nanook, did you meet with any solution to the above, i have the same problem…let me know if you got the answer! thanks.

Hi, I have the same problem also!

hi there, gotmy balance shown at least, still trying to redelegate staking that was too high…but trezor solution 2. via Troubleshooting · vacuumlabs/adalite Wiki · GitHub

This happened to me as well just now. I figured out what the problem was although i don’t know if you have the same problem. My issue was that i used the “standard wallet” when first using yoroi, but never after that. months later i forgot all about the standard wallet. Go to trezor Suite and go to the standard wallet. when it asks you for the passphrase in Yoroi, don’t type anything on the Trezor (just hit “ENTER” on the PC, which is what you do for non passphrase (non hidden) trezor accounts). That worked for me, hope it does for you

How did you resolve it? Have the same problem

Any update or solution? Same problem for me.

I have the same problem as well.