Yoroi Wallet Address Invalid


I am trying to send some ADA from crypto.com to my Yoroi wallet and I get an error that the address generated by Yoroi is invalid. It’s a Shelley wallet and I have tried generating new addresses but all come up as invalid even though I am scanning the QR codes.

Does anyone know what the problem might be here?



I dont really know crypto.com but are you able to select different networks for the transaction? If so check if you selected the Cardano network.

Crypto.com supports shelley so should be fine, can u share a screenshot?

How to buy/withdraw ADA crypto.com

Thanks for replies.

I get this message:

I have been able to send from a yoroi wallet to crypto.com it’s just sending back which is the problem so the problem must be on the exchange side.



But as u can see it’s saying something about network type…

Yeah it seems like you selected the wrong network type.

Could you make a screenshot where you see the selected network type?

It’s only Cardano option on the app:

It doesn’t give you any more information that the screens above, I then scan the QR code from Yoroi and that’s when I get an error. I’ve also tried copy pasting the address in directly and get the same error message. It does it with any address i generate from Yoroi.

I have sent ADA from the exchange before so I wonder if it has a problem with addresses generated by Yoroi.

Well then id contact the support from Crypto.com.

Not sure whats the issue here but imo this has nothing to do with the Cardano network.

When more exactly? And u sent also to a shelley wallet or to a byron wallet? Try to add a byron address

ah I’m not sure what era wallet it was as it wasn’t on Yoroi but I have tried again this morning with a newly generated address and it is now working, I will put it down to a bug on the cyrpto.com side.

Thanks for replies, it’s really appreciated.