Yoroi wallet lost money when delegating (Yoroi hacked ?)

After installing the yoroi wallet in firefox in mid Dec 2021 I then generated a new wallet with a 24 word seed phrase.

The address it gave me was : addr1q8p6wc5mmy72rkel5445rvrk3ved06uw7teqp4daj7e3zh394z9729q3k2ww3yttl8uva7kl5vmzqa73lkyvqnf57hesyy76et

I sent 999 ADA to this address and then it appeared in the yoroi wallet. I then chose to delegate the 999 ADA to a staking pool listed in the wallet that was available. I left it for a few days and noticed there were no rewards showing and the wallet was very slow. I went to remove my stake and it said the final balance in my wallet would be 14 ADA after revoking the stake.

Then I deleted the wallet and tried to restore it on a fresh install, as I found no other wallets that do the 24 word phrase I had to use the yoroi wallet again. this time after restoring the wallet, it gave me a completely different address !?! with 0 balance…

So I looked at the original address on ada explorer and it says that the ada I tried to delegate was immediately sent to some other address that only has that balance on it.


I think this is a hacked wallet… am I wrong ?

Yoroi does not have 25 word seed phrases.

Its own wallets have 15 words. It can deal with the 24 words of Daedalus.

A lot of other wallets, e.g., Adalite can deal with both seed lengths.

You are right, it is 24 not 25

That’s totally normal. Every introduction tells you that it takes three epochs (15 days) until rewards are arriving in the wallet.

Doesn’t look hacked to me. Both addresses belong to the same wallet that still has approximately 997 ADA in it. In fact, you probably sent it from one to the other address, when you delegated. A wallet consists of many addresses and most wallet applications use different change addresses for the outputs of transactions (like staking/delegating).

You could try restoring it in adalite.io to see if it’s the correct seed phrase.

Thanks for your help. sorry for the confusion, I was using a different wallets pass phrase, hence the different time frame and seed phrase, the reason I went through all this though was that the wallet said my final balance when I revoked the delegation key would be 14 ADA… ?

I don’t know what you mean here. Yoroi has no interface element that projects what would happen if you did something.

There is nothing in your wallet that has a balance of close to 14 ADA.

Your total balance is much higher:

But you do not have any rewards, now.
You will get around 0.458 ADA as rewards tomorrow (if you do not deregister before that):

No “14” there at all.

This guy opened 2 topics … and no issues after all :slight_smile:
He blamed yoroi for no reasons :thinking:

well, there are issues, that is why I want to withdraw, it’s just that the issues are not as dire as I thought, which I am very glad about but still not convinced of given the other issues that have been reported and the 0 balance in the message I get. the whole UI and system lag is terrible, hence why I don’t trust it

ok, but you can’t call YOROI a SCAM man, you are free to migrate to another opensource wallets

well, I was jumping the gun there a bit, I was burnt pretty badly before so I guess I am gun shy, I am going to head to Daedalus and see how that goes, I remember it being quite good back in the day

daedalus is a full node, so you will need more HW resources ( RAM ~16G) to use it.

Well, yes, if you have some kind of malware on one of the systems that hold your secrets, you are toast. That’s why nearly everyone recommends hardware wallets to be really, really safe.

Still can’t reconstruct what you are talking about there. There is no 0 (or 14) balance if you are looking at the correct wallet.

The lag is not that bad. Takes a few seconds on my system, when first opening Yoroi, though.
The UI may not be perfect, but cryptos are a little complex. Haven’t seen much better wallet apps that find a better compromise between showing what happens and not overwhelming the users.

If you are complaining about system lag with Yoroi already, Daedalus is perhaps not the right choice. Its connecting to a full node takes ages on every startup (which is unavoidable, but if you find Yoroi too slow, probably not your kind of wallet).

Totally off-topic: I see that happening regularly. I would suppose new users of the forums have fears that their issue gets overlooked and therefore reply to a few threads that seem fitting, open threads in multiple categories, …

Since I’m looking at the complete “Latest” list, I see all of them. Given your spectacular response times, you probably do something similar. But I can somehow understand that new people cannot really estimate that this forum is low-volume enough that it is probably enough to open one and only one topic and not get overlooked.

1 Like