Adalite - transport interface not available error

Hi there,

Been able to connect seamlessly to adalite whenever needed with ledger nano x - today confronted by the following error upon trying to connect.

TransportInterfaceNotAvailable: Unable to claim interface.

I can confirm that other resources/wallets (non-cardano) can connect with my ledger fine, all are disconnected, including ledger live.

I am using adalite/nano x via apple, google chrome. I’ve restarted the mac clean, shut all apps possible, browser windows - and attempted connect via the hardware wallet web usb route as all times previously which have worked great.

Any suggestions? thanks.

Change the browser, if I remember well could be some issues with chrome

Thanks but this doesn’t work, in fact with safari it’s now a different error.

TransportCanceledByUser: undefined is not an object (evaluating ‘navigator.usb.getDevices’).

Ok I’ve now discovered I can’t connect with another non-ledger wallet either. Ledger live still seems to work fine. Anyone encountered this before or have any suggestions? Ledger web site is not particularly helpful.

Ok further update - looks like a browser update is causing the issue, and particularly pertinent to several non-ledger wallets. Chromium browsers in particular. This is a live issue today.

As a matter of fact, Chrome/Chromium was reusing part of Safari code base. I do not know if that’s still the case, though.

Hello, did you ever find a resolution to this issue? I am having the same issue unfortunately. I have ADA staked, but no way to access as of now.

Most likely it’s something with your browser. It can be cache issues, extensions or so.

Rest your web browser (Factory settings) completely and try again.

I gave that a shot & it’s still happening. Sent the error to Adalite… we will see what happens

Okay, I have another theory. “TransportInterfaceNotAvailable: Unable to claim interface” means that it might be being used by another platform while you try to access it.

So close everything you have on, restart your computer, and try to access your wallet only using adalife interface. Don’t open anything else (Wallets, apps…etc)

Let me know how that goes.