Nami HW Wallet won't connect to Ledger Nano X: "An error occurred"

Hi all…
I’m trying to transfer an asset from my Nami hardware wallet (via Ledger Nano X) to one of my regular Nami wallets. Using Google Chrome on a MacBook Air.
When I get to the “Connect Ledger” command, I connect my Ledger as usual, enter my PIN and open Cardano, which as usual says “Cardano is ready”.
Back to Nami, click the “Confirm” button and nothing happens, except an error message in red: “An error occurred”.
I tried restarting my Mac and I checked all of the the cable connections. Even used a different cable. My ledger connects perfectly to the Ledger Live website so I’m pretty sure there’s no problem with the physical connection between Ledger and my MacBook.
Everything else works perfectly, tranfers to and between my other Nami wallets and sub-wallets are unaffected. Just the connection to my Nami hardware wallet… I must’ve tried 20 times now over 2 days in case I was simply missing something.
Any ideas?


Connect your ledger on and transfer from there

!!! If someone will contact via DM and ask for seed words its a SCAM, please report it!

Stay safe!


1 Like

Thaks for the instant reply (and scam warning…)
I’ll give it a go.
Have a great day!

1 Like

Perfect… thank you so much… I’ve no idea what wizardry was involved but t.b.h. I don’t care :slight_smile:
Many thanks!

1 Like