Unable to pair Ledger Nano S with any ADA Wallet

I contact you because I’m not able to pair my Ledger Nano S with any ADA WALLET.
I have no problem with Ledger Live.

The version of CARDANO App instaled on my LEDGER is v3.0.0.
The version of Ledger Nano Micrologiciel is v 2.1.0.
The Nano S is unlocked and the Cardano App is open when i try to pair.
I tried with Google Chrome and Brave
I tried to connect my Ledger with YOROI, Adalite, Nami, CCVault.io.
On Adalite, I have the following message
*“TransportCanceledByUser: Access denied to use Ledger device.”
On Nami : “Device Not Found”
(Ledger Live is closed.)

I tried to uninstall and Reinstall CARDANO APP.

That’s weird because, some days ago, everything was All Right (Chrome + YOROI).
And now, my ADA are blocked on my Ledger

I need help. Thanks in advance

Extra debug steps you may not have exhausted:

  • Check latest Ledger Live for firmware and/or Cardano ADA protocol app updates!
  • Ask Ledger for support: https://support.ledger.com/hc/en-us/categories/4404369571601?support=true
  • Try deleting cache or using incognito mode in browser
  • Try yet another browser (Firefox?)
  • Live boot into a clean operating system from USB
  • Try a different computer entirely
  • Restore your recovery phrase onto a brand new Nano S (last resort if you suspect hardware failure to be the cause)

Did you have the Cardano app open on the Ledger when you tried to connect it with a wallet software?

Yes with mention “Waiting for Command”

Hello @Remy132639

This sound like your Ledger is not connecting to your PC.
Make sure you are using original Ledger cable. There are many cables out there that will fit, but they are not data transfer cables (charging only).

Try unplugging the cable and plugging back in while Cardano App is open. See what happens then.

I tried to unplug Cable :

  • with Cardano APP opened or
  • in the main menu, witj Cardano App not opened

With an other computer.
No success

It’s weird because I don’t have any connection problem with Ledger Live.
I use original USB cable.

Could you please try to use a different computer and then try to connect it via adalite.io?

So if it’s not hardware blocking your connection, then it’s software.

Did you install any new Ledger Nano S apps recently? If so, uninstall them. Ledger Nano S can support only 3 to 7 apps at one time (depending on a model). It’s only Nano X that can support 100 apps.

Make sure if you used Bluetooth to connect to end that connection. If app is being already accessed it won’t let you connect.

If on Windows, then there was recently an update that you may need to install manually. Go to Settings/ Update and Security and check for updates. Install, then restart. Just to make sure right click the app icon and ‘Run as an Administrator’

I tried with an other computer. I have the same problem.

On my computer, I have installed :

  • Ledger Live
  • Metamask (chrome / Firefox)
  • Yoroi (chrome / Brave)
  • Nami (Chrome / Brave / Edge)

On my Ledger Nano S. I have only Cardano App installed.
Nano S don’t allow bluetooth connexion.

I gonna chech Windows update

Windos Update ok.
All update even optionnal are done.

It’s like connection are not allowed by Ledger Cardano App ?

I’m desperate

Then you need to contact Ledger support. This may be new issues.

And, what about, re-initiaize my Ledger using seed phrase ?
Do you think, there is a chance that my sofware problems be solved ?

I pair my Ledger Nano S with my Yoroi Wallet.
However, I can only use the hardware validation in the browser using the Yoroi Browser extension.
The Yoroi mobile app on android has issues with using Ledger Nano S - I have not tried recently, but that was my most recent experience.
Nonetheless, I am perfectly fine using Yoroi with Ledger Nano S and confirming transactions in a web browser using the Yoroi web browser extension.
I have been using Yoroi with Ledger Nano S this way successfully for about a year now with no complaints or issues.

Now, I can access my LEDGER and make withdraw with my YOROI Wallet in Chrome.

But I cannot connect my LEDGER to any else ADA Wallet :

If you have any idea to solve this issue …

I used the my ledger S on NuFi wallet and it worked fine (new adalite wallet). Also works great on Daedalus wallet.

Make sure your ledger is updated and the Cardano app is installed from the manager on you Ledger Live app.

Unfortunately with my Ledger S it only had room for Cardano app and had to delete all other chains from my ledger… now use my ledger strictly for Cardano.
Will have to buy a Ledger X with more storage one day for multiple chains on a ledger.

Hope that helps. Good luck !

You need tu switch blind signing on, on the ledger device

You do not need blind signing for Cardano ever! That is a hack for chains that proxy transactions or otherwise use a non-deterministic format that would always be rejected by a HW wallet. The ONLY time I have ever had to use blind signing with a Nano S was for Solana delegation. Cardano and other chains do not have this problem.

Blind signing explained

When in doubt: Think twice, do nothing.

1 Like

Did you manage to solve the issue Remy?

Yes I did.

I understood after multiple try :
-1- the first time you connect your harware wallet to a new browser, a prompt window open. you have to select your Nano S to continue,
-2- this step is not necessary after because browser recognize your harware wallet.

I used for several weeks my Nano S with the same chrome browser. (without step -1-)
I had to change configuration : not the same browser, and from this moment, Each time, I was waiting in front of the connexion window that sommething happens. But Nothing happens …
Shame on me :-).
The strenght ot habits.

Perhaps my poor user experience helps someone.