Can,t connect to network after restore


#1

I have tried to restore my wallet to another pc, the restore have failed although it says that the wallet have been created and since then i can’t connect to the network with my original wallet please advice i don’t have access to my ADA.


#2

You need to close Daedalus, then delete directories Wallets-1.0 and Secrets-1.0 from %appdata%\Daedalus folder, then open Daedalus again - it will open like in the first time.

If it does not open again - also delete folder DB-1.0 from the same folder. And start Dedalus again - this time it will resync the whole blockchain again (might take few hours).

Then it will open like in the first time and propose to create or restore a wallet. Select “Restore wallet” and enter your 12 secret words - then it will start restoration. Do not close Daedalus or the computer while wallet is restoring! It might also take few hours, but you need to run Daedalus untouched until you see the wallet in the interface.

Also turn off sleep-mode on the computer, so it does not turns off by itself.


#3

Hi, thank you for the response. I have thought of these steps and i have tried them on my other pc with no results so i am a little worried about deleting the wallet. What if it never restores and lose my currencies. Is there a restriction of having two wallets at the same time? I am just curious why did this happened in the first place.


#4

The “currencies” are on the blockchain, not on your computer. As long as you have the 12 word key - you may access them from anywhere in the world.


#5

Yes but since i have tried 2-3 times with the pass phrase and it doesn’t work am starting to have doubts about being correct although i have tripple checked it when i wrote it down. Anyway thank you again for your response.


#6

How exactly it does not work?

What do you mean “restore have failed”? What did it show to you?


#7

When i put the phrase and hit ok it prompts me to create or restore a wallet again like nothing happened and when i try again it says that the wallet already exists. How long does it take for the wallet to restore? and if it actually is being restored and i have to wait, shouldn’t it show me some other message or a screen that is actually being restored ruther than asking me to create or restore a wallet?


#8

That’s fine, just do not close the wallet and wait until it’s restored (can be couple of hours). You can see a restore icon top right of the GUI.
The root cause of this, cos you did not create an empty wallet first. If you would’ve then the GUI would NOT fall back to Restore dialog but to your firstly created wallet.


#9

Thank you, will try that and let you know.


#10

After hitting “ok” on the wallet restoration you need to just wait for the restoration process.

Few hours. Depends on the computer.


#11

If this is a potential source of this issue then it might be a good idea to implement a slight trick in the Daedalus app: instead of letting the user manually and globaly turn of power saving, the app - under certain circumstances (wallet restoration) - could programmatically move the mouse cursor by 1px up and down, once every minute. This interrupts the sleep countdown at OS level.


#12

Thank you it worked i left all day to do the restore and finally they showed up!


#13

I faced the same problem again. So i uninstalled and reinstalled the application it started to synch the blocks at about 99.5%. It seems to be the quickest way.


#14

How did you face the same issue if you already had your wallet restored?


#15

It got stuck on connecting to network again. I’m not totally sure but it might have to do and with tha shortcut on windows taskbar(it’s new i pinned it when i installed the app). When i open it from the desktop shortcut it opens normally.


#16

Yes, you need to always use the desktop shortcut


#17

Same issue for me. From a ui perspective would be nice to know that its still thinking in restoring my wallet. I waited a long time as well for wallet to snyc but no luck…Will try again.


#18