Can’t Send NFT on Daedalus

Hello everyone. I’m dealing with an issue with Daedalus where I cannot send an NFT token and I am receiving a “Transaction Confirmation Failed”.

I initially opened a hardware wallet on Nami and everything was fine until I paired the HW with Daedalus to stake ADA. This was my mistake as I didn’t know that Daedalus and Nami don’t interact well with multiple and single address.

I immediately began receiving an error notification on Nami. “We have detected that the current wallet seed has been used with another wallet.” Along with mention of a difference of Real Balance.

I saw the solution was to internally transfer to the Nami wallet. Which I proceeded to do. I transferred my tokens and a majority of my ADA. I however had a group of 5 tokens that I accidentally sent only 1 of on the initial transfer.

Now when I try sending the remainder of the 4 tokens out I get “Transaction Confirmation Failed”.

I don’t see the tokens in my Nami wallet but I do see them in my Daedalus which is strange.

I’ve unstaked my ADA. Tried sending to different wallets. Transferred everything from my Nami wallet associated with the HW wallet to another Nami wallet. Updated Daedalus. And still nothing.

What’s confusing is I was able to send my other NFTs but I can’t send this group of tokens. I’m at my wits end here and I’d hate to lose that group of tokens.

Does anyone have any suggestions on how to fix this?

Try to connect the hw wallet on and try from there; perhaps there are some issues with the daedalus


Don’t worry. The tokens are obviously in your wallet, just not, where stupid Nami can see them. That’s exactly the “We have detected that the current wallet seed has been used with another wallet.” problem you started with.

If @Alexd1985’s idea of just using Adalite does not work:

How much is left in the wallet together with the four NFTs?

Tokens have to be accompanied by a minimal amount of ADA. If only this minimal amount is in the wallet at all, they cannot be transferred anywhere else, not even another address in the same wallet, because the transaction fee can’t be paid without going below the minimum. Solution in that case would be to simply load a few ADA extra on the wallet with the NFTs.

Thank you. I will give it a try when I get home.

I’ve transferred more ADA in there in the chance that it was a deficient transaction fee issue . I have atleast 15 ADA in there which should be sufficient to transfer the 4 tokens.

I’ve found another pain is the lack of a “send all” function for Daedalus. I guess it’s a good failsafe for those who may accidentally click and send, but trying to calculate how much to send with included transaction fee to get a balance of 0 is tedious :weary:

This completely worked. Wanted to drop by and thank you so much for your help!