Cannot have Daedelus testnet to work


I’m want to play around with Cardano Shelley and incentivized testnet.

Unfortunately I get stuck, on what should be the simplest thing: having Daedalus to work. I’ve simply installed the testbet version of Daedalus on Debian 9. But it never worked. It gets stuck to “connecting to network”.

On the same machine I have Daedelus mainet working perfectly.

Am I the only one in this situation? Any idea to solve it?

(I tried all this and this without success )

Go to “Daedalus state directory” --> “OPEN” --> “chain” folder --> delete all the files. Then, close Daedalus and reopen.

Verify that “blocks.sqlite” file (chain) grows while Daedalus synchronizes. The current file size is ~274MB.

Many people have been having that problem, including me. I find that, if I just leave it running in the background, it usually connects eventually. It can take an hour or more though.

Ok after waiting a long time while the wallet seemed stuck, it eventually launched.

Unfortunately this is not the end of my problems. I try to recover a wallet with a 12-words recovery phrase as mentioned here: , in the page where I set the wallet name and password, I get “an error occured”, then if I try again “The wallet you are trying to restore already exists”.

But the wallet never appears in daedelus.

Any idea?

i think there is a thread in this forum about exactly that issue :slight_smile:

check it out :slight_smile:

Deleting the wallet directory remove "The wallet you are trying to restore already exists” in the first time, but I get “an error occurred” and it starts again with “The wallet you are trying to restore already exists”.

if I delete the chain directory I will need hours to download it again. Is this really necessary?

You can leave chain directory as-is, you do not need to delete it.

But then it does not work, I’ve deleted the wallet directory many times, and was unable to restore my wallet everytime

You’re only deleting the wallet folder, instruction was to clear the state folder - of which if you want to avoid sync again, you can leave your chain folder - and then install using the downloaded setup once :slight_smile:

PS: Also, Connecting to Network status means node is trying to bootstrap for most cases - unless you’re bootstrapping from a bad/overloaded node, you can hit restart if your chain folder isnt moving for long. Also, you can ofcourse - use Yoroi and skip all this if you’d like to.

1 Like

So which folder should I delete under Linux?

Because the doc says that under linux the state folder consists in two folders: wallets and chain.

Delete wallets.

Delete wallets.

I tried it several times. The first time I try to restore the wallet I get “an error occurred” (I see then that new files appear in the wallets folder) and after it starts again with “The wallet you are trying to restore already exists” until I remove the wallets folder. But it never worked as expected.

OK, sorry but I have no idea what’s happening there. I think you should try deleting the chain folder as well, I understand why you don’t want to but in this case I think it’s worth the trouble. The other thing you can do is submit a support request.

All except chain should be OK if you’re getting to restore page, followed by install using setup again

1 Like

The problem is solved for me with latest Daedelus version 2.2.0

1 Like

I found with 2.1.0 restoring rewards wallets worked. Restoring balance wallet broke everything.
However, with 2.2.0 all is well. restored rewards wallets, then balance wallet and working great. Even loads within a few minutes instead of many minutes or hours.

Anyone have issues with Mac? On another thread others are reporting even with 2.2.0 nothing is working on a Mac.

1 Like

Yep. Still an’t even download 2.2.0 on a Mac / Catalina.