Testnet wallet won't sync

I’ve just set up my testnet wallet and a reward wallet. All looked to have gone fine and I was about to delegate when the wallet closed and then began to sync. But it’s just stuck trying to connect now and not syncying. First green light on, other two just grey.

Anyone else had this issue?

try this solution

Same problem, I start the “Daedalus Incentivized Testnet v1” evrything is ok for a while, I’ve delegated my ADA and then after an hour or two the wallet disconnects and start syncing for no reason. And to make things worst, it’s syncing forever :frowning: My internet connection is fine. The troubleshooting guide is general, it doesn’t target the issue directly. Are there any error codes that we can use to troubleshoot ? When I restart the node it’s working again ,but it’s not fun to restart it every hour or two. If the staking is going to work we need stable wallet.

Daedalus (all versions) doesn’t stop syncing when it reaches 100%, it carries on in the background, that’s normal. Of course when it fails to sync that’s not so great, but seems to me the main question is: if you managed to do the delegation, why keep it running? You could run it once a day to check rewards – or leave it 2-3 days or more. Meanwhile, there are no error codes, nor anything you need to or could do, it’s a network problem.

Ok, I’ve got the impression that it’s required for the wallet to run 24/7 in order to be able to participate in the staking. But if that’s not the case then it’s not that big of an issue for now.

“Meanwhile, there are no error codes, nor anything you need to or could do, it’s a network problem.”
Is it my network problem or the testnet network problem ?

Actually I found error codes in the logs of the wallet, if I’m not mistaken. Mine is “os error 10060

INFO failed to connect to peer, reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (os error 10060)

And another one “os error 10061
INFO failed to connect to peer, reason: No connection could be made because the target machine actively refused it. (os error 10061)

I tought that this might be related to the constant disconects but I don’t know.

It’s not you, it’s them! :rofl:

1 Like

I’m also having an issue with the Testnet wallet not syncing. This has been running for about 10 hours and the sync started at 90+% but is going down. Now it’s down to 68%. I had this problem with an update to the Daedalus wallet. The solution that time was to delete some files. I don’t recall which ones.

Is this something I should just let run or is there something I could do? Thanks!

Have you restarted it? If not, do that first.

Thanks! That did it. I started up the computer and the app this morning and it worked.

I don’t recall exactly but I think the first time I got my balance into the app using the recovery process. Then the syncing started. Anyway all is well now.

1 Like

I had similar issues in the beginning, but it connects now much faster (within 1 ~ 2 minutes) after the first connection. And I got my first staking reward today. Great :smiley:

1 Like

It seems that restarting is only temporary. If I leave the app running it will eventually go back to they syncing. Once it starts that it doesn’t end. The percent synced declines. But if I quit and restart it’s OK.

I solved the sync problem by adding in node_config.yaml
the listen_address and public_address since I’m behind a NAT router like this:

“p2p”: {
“listen_address”: “/ip4/”,
“public_address”: “/ip4/79.xx.xx.xx/tcp/3100”,
“topics_of_interest”: {