Daedalus Testnet Stuck Syncing Blocks

I’m hoping someone can help clear this up. The wallet keeps getting stuck on 99% syncing blocks. The logs say:

Jan 10 12:04:04.385 INFO failed to connect to peer, reason: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (os error 10060), node_id: a644058248c0d9721fdbef3f3996e65e5fe4df844f9ae597, peer_addr: 76.xxx.xxx.xxx:4000, task: network

Hoping to get to the 100% mark! Thank you.

just close and restart it :slight_smile: i have the same problem from time to time.

Thx! I tried that and it worked this time. Strange, I’ve done that several times before and it would still hang up. I think once it’s actually connected. Glad it’s working though. If it happens again, will advise. Thx again!

ye i have to exact same problem :slight_smile: sometimes it works and sometimes it doesnt :smiley:

just close and restart it once or twice and it will work again :smiley:

1 Like

Since getting past the original issue, daedalus status and cardano status on the diagnostics page keep showing everything connected and synced, but after a few hours, the sync part un-sync’s. Why does the sync keep dropping?