Cardano Wallet Not startnig [solved, latest version works fine]

The wallet worked only the first time ever i installed it,i have bought some ADA,and after few days i tried to open it
and it’s stuck at “Syncing blocks 100%” i have tried to remove the files and install again,and on another computer in the house and it’s the same

what should i do ?

There is a new version of Daedalus, install it. It may solve the problem. Download it from here

1 Like

Oh God i`ve installed it and suddenly it’s working…


Will Daedalus have an update link within the wallet? I opened my wallet this morning and it did not offer me any updates.

Of you have a recent enough version of Daedalus - it should offer you an update. If it dies not - you can always download latest version from and install it over you current version.

So if I do decide to install the latest, I wont have to uninstall existing wallet. Just run new install and it should overwrite it?

As far as I know - yes. But if it does not work for some reason - you might have to uninstall current version completely first.

1 Like

I downloaded and installed on top, no probs at all. :smile:

CH previously said deployment could take up to 12 hours, so current installation offering update option might not happen for a little while…