ccVault Thinks Ledger Nano S Does Not Have The Current Cardano App

Greetings All,
I am trying to move ADA with my ledger using ccvault. It has always worked in the past. This time I got the message “Ledger app version too old, please update firmware and Cardano app version on your Ledger device.” So I went to ledger live. My firmware was up to date according to ledger live. Then I deleted the Cardano app on the ledger and installed it again. Then I went back to ccvault to move funds and I got the same message again. So I rebooted my computer and tried again with the same result. Is anyone else having this problem? Thanks


Try to connect the ledger on → hw wallet → unlock with ledger (webusb) and perform the transaction from there


That is a known bug of version 1.6.1 of the extension. Verson 1.6.2 fixing it is already submitted to the app store and just has to be released by Google.

Until then, you can use the web version at (or as @Alexd1985 said).

1 Like

Thanks @Alexd1985, Thanks @HeptaSean
Yes, worked fine.
Next time I will try

1 Like

Version 1.6.2 is now available in the Chrome extension store. If you have a problem using Ledger with Eternl saying “Version too old.”, close the browser (all windows) and reopen it. That should trigger the update. Version can be seen at the bottom of the extension.

Thanks @HeptaSean,
Eternl is a great wallet.
I am looking forward to using it again.