Cardano [ADA] staking with Ledger Nano S and Yoroi-Shelley: Something unexpected happened. Please retry

Hi there :slight_smile:

I’m using the Yoroi-Shelley Ledger Wallet together with my Ledger Nano S with Chrome. Every time I want to Delegate coins to a pool, I’m getting an error which says ’ Something unexpected happened. Please retry.’. This happens right after the plugin want’s to connect to my Ledger and I clicked the right button on Step 1 in the process. I’m using version 2.0.4 and the latest Yoroi Chrome extension. Can somebody please help me?

Thanks, Phil

Hey @Philipp_Pendelin welcome to the forum!

I’m pretty sure that you are missing an update from the Cardano app on your Ledger device.

Please make sure you are using the latest version of Ledger Live and the latest update from the Cardano app on your device.

Cheers
Fabian

Hey @Zyroxa, thanks a lot for your quick response :slight_smile:

From my point of view I have the latest versions installed (ADA 2.0.4). Also my Ledger firmware is up to date (Nano S 1.6.1).

Thanks, Phil

Does the same thing also happen on Adalite.io?

If yes you may want to join the offical Discord channel and ask Sebastien for support in the Yoroi-support channel.

Cheers
Fabian

Yes - unfortunately but with a different error: Transaction rejected while signing: Ledger device: General error 0x6e06. Please consult https://github.com/cardano-foundation/ledger-app-cardano/blob/master/src/errors.h

I just ordered a Nano X - hopefully this makes things better :slight_smile: Thanks again for your help.

Makes imo no sense.

Imo before you purchase another Ledger device double check for the recent updates from :

  • Ledger Live
  • Firmware from your Ledger device
  • uninstall and reinstall your Cardano app on your device

Cheers
Fabian

HI Philipp, did you fix your issue with Yoroi wallet? I get the same error…?

Do you use the most recent version of the Cardano app on your Ledger? If yes and its still not working try to use Adalite.io in the meantime.

Cheers
Fabian

Ledger only has 1.1.1 Cardano Firmware. I can not find any resource that says Ledger should have 2.1.1…?

OK - Finally found that Ledger needed to be updated, not just Cardano App. The entire system had to be updated…

1 Like