CnTools Migration

Hello all,
I have an old pool that I want to move all the payment and pool info on to a CnTools server that’s already set up. I know the information has to be on two priv folders, wallet and pool, but the naming conventions are off from both.
For the pool that’s getting moved, I used the Stakepool 247 guide and all the naming conventions are the same.

But I want to move over to CNTools for ease of operation. I’m already familiar with operating it so I want it moved over.

I know that for example, the wallet files are called these in CNTools

But in Stakepool 247 we got all of these

Anyone have insight on what should be renamed to what?


Yeah, I have it, wait 1 min


It was time ago and I can’t find the file but let’s see:

  • wallet files which should be inside priv/wallet (I see u have 2 wallets … this means u will need 2 folders inside priv/wallet) …

! Before to rename keep a bkp for the old files, till u will have the confirmation that everything os working

  • mywallet (u don’t have stake files so I believe this one is not registered/delegated)

myWallet.addr → payment.addr
myWallets.skey → payment.skey
myWallets.vkey → payment.vkey

  • owner wallet

poolOwner.deleg.cert → delegation.cert
poolOwner.payment.addr → payment.addr
poolOwner.payment.skey → payment.skey
poolOwner.payment.vkey → payment.vkey
poolOwner.staking.addr → reward.addr
poolOwner.staking.cert → stake.cert
poolOwner.staking.skey → stake.skey
poolOwner.staking.vkey → stake.vkey

Now if u will go on cntools - wallet - list or show u should be able to see the balance and for test u can go to funds - send and try to send few ada between wallets

Now for the pool files … priv/pool/…

myPool.node.counter → cold.counter
myPool.node.skey → cold.skey
myPool.node.vkey → cold.vkey
myPool.vrf.skey → vrf.skey
myPool.vrf.vkey → vrf.vkey → →
myPool.metadata.json → poolmeta.json
myPool.node-000.opcert → op.cert !!! Only if it’s the recently/latest opcert created; if not copy the latest file
myPool.kes.counter → kes.start
myPool.kes-000.skey → hot.skey
myPool.kee-000.vkey → hot.vkey

To check if everything is fine go to cntools - pool - rotate and try to rotate the kes (before check inside cold.counter the counter for the next certificate)

or u can go to cntools - pool - modify and try to modify something, or keep the actual parameters … go till the end and check if everything is ok


Thank you! I’m going to give this a shot

1 Like

So I tried to do something with the pool. And I made sure the keys are here

But when I tried to run this operation I got this error


1 Like

Yeah, because u still miss a file (check if u have it somewhere… ) pool.config

1 Like

Is one of these supposed to be pool.config?

1 Like

type cat myPool.pool.json and share the output

1 Like

Where should I type that out?

1 Like

anyway I don’t think is the pool.config file I will check …

If u go to cntools - pool - modify are u receiving the same message?

Slightly different error
Now it says vrf.skey

ok, then try to locate if u have the pool.config file (or something with config) some where…

btw type ls -l inside pool folder (where the pool files are located) I want to check the size of the files and compare them (cover the username)


And I just dug around the old pool and I didn’t find any config files except for the genesis files.

same as mine, so the files are ok

If you open up your config file, are the contents similar to this?

never mind, pool config will be created automaticalIy I believe after - pool - modify operation

I had an error after I tried to modify the pool though. Claimed missing keys.

what error? Can u share it?

also if u type cat op.cert do u see type: “NodeOperational certificate” right?
Actually I believe u will need pool.cert file … can u find this file?
if u type cat pool.cert u should see type: “CertificateShelley”

This is the error I see

And where should I type those commands?

Sorry it took me a while to get back.

on pool folder, where the files are located