Help please with server transfer

Hi there - after realising that my Block Producing Node may have not been configured properly I have configured a new server and transferred over my pool certificate and my keys so as to keep my original pool and registration. This time I am using CNTools to set it up the new pool but I am lost when it comes to transferring over the pledge and the payment address. CNTools only allows me to import wallets with sets of passphrases. Is there anyway I can import or connect my old payment addresses and the address that holds the pledge to the new server. Alternatively should I just pledge again to a new wallet and try to transfer the old pledge. I have tried on Telegram but not had much luck there. Thanks.

Now you should check if in priv folder you have imported all informations about your wallet…( in priv folder you should have other 2 files for wallet and for pool, check if something missing because cntools use those folders for wallet and pool informations);

be sure your scripts are pointing to that folder (check the path).

Hi there and thanks for your help. At the moment I transferred the following keys from my decommissioned server and placed them in the folder …/priv/pool/MYPOOL/

These were
kes.skey which I renamed to hot.skey
vrf.key which I kept the name the same
node.cert which I renamed to op.cert

I changed these after reviewing my original setup using the Coincashew guide and assumed that the node.cert is the op.cert and the kes.skey is the hot.skey when setting up using CNTools documentation.

I note that there is a folder under the path …priv/wallet/payment_addr which is empty - should I copy my payment.addr file from my old server to this folder?

Also please tell me if I have this wrong and if I need to copy other files over to the priv area?

Many thanks once again.

yes, there are kept all informations about your wallet, and CNTOOLS extract informations from there

here how mine looks:

/opt/cardano/cnode/priv$ cd wallet/
/opt/cardano/cnode/priv/wallet$ ls -l
total 4
drwx------ 2 4096 Dec 1 00:36 chrtywallet
opt/cardano/cnode/priv/wallet$ cd chrtywallet/
opt/cardano/cnode/priv/wallet/chrtywallet$ ls -l
total 36
-rw------- 1 103 Dec 2 12:17 base.addr
-r-------- 1 243 Sep 3 15:23 delegation.cert
-rw------- 1 58 Dec 2 12:17 payment.addr
-r-------- 1 224 Dec 1 00:36 payment.skey.gpg
-r-------- 1 190 Sep 3 13:29 payment.vkey
-rw------- 1 59 Dec 2 12:17 reward.addr
-r-------- 1 185 Sep 3 15:22 stake.cert
-r-------- 1 220 Dec 1 00:36 stake.skey.gpg
-r-------- 1 186 Sep 3 13:29 stake.vkey

Thanks - sorry just to clarify then - I should copy my payment.addr file over to the priv/wallet/payment_addr folder?

I am still not sure if the certs and other addr files go into the /priv/pool/mypool folder or the /priv/wallet folder - is there a config file that I need to change for this??

priv/wallet/payment_addr folder … you should have priv/wallet/your_wallet_name and inside the folder you should have payment.addr as you can see in my case above

sorry I don’t know to tell you 100% if the name of the folder is really matters… but I know that in cntools my wallet is called like my folder… if you understand, but I believe you can give what name you want

Ok thanks - I will give this a try

Hi there - not sure if you can help again but I have put my payment addr in the wallet folder along with the signing key but when I view the wallet on CNTools I get the following error

Not a supporeted wallet - genesis address?
Use an external script to send funds to a CNTools compatible wallet

But if I register a new wallet and update my registration will I lose the existing staking information from my external wallets that are staked to the original configuration?


Sorry, I can’t help you, I’m not sure about this and I don’t want to say something wrong.
I see the script maybe this will help you but… again I don’t want to tell you something about I’m not sure.
I think the script does the same thing like cntools…create a new wallet/address

I found something about… but you need read carefully first

Actually I just worked it out - I added the stake keys into the wallet similar to the other wallets that CNTools created and the wallet shows as registered. Problem now is the pool is not showing as registered

I’m glade you solved the wallet. pool not registered…do you have all the files required inside the folder? do you have metadata file?
look what you need to have in that folder (pool/pool_folder_name)

1327 Oct 25 16:39 hot.skey
183 Oct 25 16:39 hot.vkey
3 Oct 25 16:39 kes.start
365 Oct 25 16:39 op.cert
626 Dec 1 00:32 pool.cert
332 Dec 1 00:32 pool.config
57 Dec 1 00:32
57 Dec 1 00:32
212 Dec 1 00:32 poolmeta.json
230 Sep 3 13:33 vrf.skey
176 Sep 3 13:33 vrf.vkey
and of course cold keys which shouldn’t be keep on server (keep them offline)

PS your pool is available on adapools and

to be sure your BP is working well see my topic

Hi there thanks again for your help. I seem to solve one problem then run into another. I have all the files listed above in my pool folder but when I try to modify the pool so I can update the registration it says no pools are available to update so I am not sure what I am doing wrong. I need to give this some thought tomorrow. The pool is showing as registered however in CNTools but I just can not edit it.

I checked your link and my BP node is doing everything right as you indicate. However I cannot update the relays in the pool registration because CNTools wont let me and if I try to run the commands I was using in my first set up I just get lots of errors because it is configured differently.

on cntools if you go to pool -> show : the output is ok?
it must return informations about your pool

also did you upload your cold keys in priv/pool/folder in order to modify your pool?

Hi there - yes I have done a pool -> show in CNTools and it returns everything including all pool ID’, URL’s pledge, margin, relays, owners, reward account etc and everything is right except for the relays which I need to update. However when I go into CNTools and pools and select modify I just get this:

Online mode - The default mode to use if all keys are available

Hybrid mode - 1) Go through steps to build a transaction file
2) Copy built tx file to offline computer
3) Sign it using ‘Sign Tx’ with keys on offline computer
(CNTools started in offline mode ‘-o’ without node connection)
4) Copy the signed tx file back to online computer and submit using ‘Submit Tx’

Selected value: [o] Online

# Select pool to modify
WARN: No pools available that can be selected!

press any key to return to home menu

which is strange as CNTools can see the pool and sees that it is registered

ok. you can contact cntools dev team via telegram, and they will help you
you can try here:
after that please share with us how you fixed it

many thanks, I hope you will solve soon

Yes I will - and once again thanks for helping

I have joined the group but it looks like there is a 24 hour wait before I can post so I will get back when I can

so you said you uploaded the cold keys in pool folder right?

maybe this will help you