Connection to network... on 1.4

Open firewall settings. If you find previous instances of Cardano or Daedalus allowed through firewall (on the list of allowed programs), erase them, and then add “Daedalus” again. This could solve the neverending Connecting to network… (helped me after trying everything else).

It is strange that Daedalus 1.4 did not trigger the firewall permissions, so that you could clearly allow it again if necessary, without all this confusion. The previous firewall settings surprisingly did not apply after updating.

So, focus on the firewall &
Long live Cardano!

1 Like

Interesting – my migration was stuck, figures not changing over a couple of hours, and what fixed it for me was going into Windows Defender Firewall exception list and allowing all instances (9 I think) of cardano-node onto the public network. (Four or five were already ok, I just clicked to tick on the others then restarted the node.)


Unfortunately, the fix was temporary. I am having the “Connecting to network” problem again, don’t really know what to do next. Have checked the firewall and enabled everything, disabled antivirus…
I wish there were some clear error codes in Daedalus.

Have you looked at the logfiles? Don’t know much about it myself but might be useful to a techy. There’s a guy on TG channel @CardanoCommunityTechSupport who analyses them.

Thanks, it has been solved in the meantime, just persisted and it finally got through.

1 Like

Eventually, after a total of about 3 days and 2 nights, it all completed. I did get dozens of network-related errors, but just let it complete, and it’s finally over.

1 Like