[Resolved] Tracking down "Connecting to Network Issue" (forum tech stuff)


#1

Allow me to introduce myself. I am a guy that loves the Cardano project that has limited technical knowledge. I am however a 30 something year old computer geek/ graphicartist/gamer that has vast experience in fixing programs that go haywire. Allot of game’s and software have had bugs, fixes and work arounds over the years that I have had to track down, research and implement. Software is software.

Problem: My Daedalus wallet will not connect to network and has not been able to for almost 2 months.

Here we go:

First off i’d like to openly invite anyone here with more knowledge then myself to correct me if I am wrong in any of my presumptions. Here is my method. First thing is first… is the daedelus wallet being blocked by my virus software or firewall. It turns out my virus software has taken over how my firewall rules (I didn’t know it did that). So I check my firewall rules. Turns out there are two entries for the Cardano node in there for some reason. Maybe that’s because the Cardano software (for some reason) has two exe files? IDK… that’s weird but okay. Everything there looks fine. My virus software seems to also be okay with daedelus and I am executing the application as administrator.

What gives?

Next step open up task manager. What is actually happening when I open up the wallet? There are 4 identical processes… however there is 0 network activity in each. Hmmm… that can’t be good. So what gives? Well… lets go back to the virus software. What is the wallet trying to do? It’s attempting to connect to an outbound TCP port. So I do a little reading and it turns out that…

TCP stands for Transmission Control Protocol. Using this method, the computer sending the data connects directly to the computer it is sending the data it to, and stays connected for the duration of the transfer. With this method, the two computers can guarantee that the data has arrived safely and correctly, and then they disconnect the connection. This method of transferring data tends to be quicker and more reliable, but puts a higher load on the computer as it has to monitor the connection and the data going across it.

Soooo… that’s probably why my relatively new computer gets really slow when it’s running the wallet. Fair enough. So where does this port lead? A little bit of google magic reveals that it appears to be something called a “registered port” located somewhere in Japan. This makes sense since the Japanese like their cardano and the wallet is trying to sync with the block chain. I ran the port through the free servie at Speedguid.net and that website classifies the port as a Filtered Port “Filtered ports do not respond to a portscan at all, they don’t appear to exist. This is the best security level for your ports, as it provides no information about your system or its existence (a.k.a. black hole)” Hmmm… a black hole. That’s interesting.

That’s all I know thus far… I must therefore presume that my internet service provider has for some reason deemed this connection as unwanted traffic to another country during the short amount of time I have been using this wallet. For those of you that don’t know, there are a tremendous amount of websites around the world that you are not allowed to see. You’re internet is not actually free to all.

At this juncture I find this to be the only reasonable presumption. If it is so then the only viable solution at this time would be to get a VPN and see if that works. If it does then it would confirm my theory. If it is true… you guys who are developing this blockchain really need to 1. do something about it soon and 2. warn people. The money I have moved from the exchange to your wallet was no small investment for me. I should have just left it there with all of my other coins I invested in. 2 weeks after transferring it to the daedelus wallet and through no fault of my own my investment is lingering somewhere in oblivion. If I can log into an exchange and collect my coins why can’t I just log into a Cardano website and do the same thing? Isn’t that what Tron is working towards besides the fact that it is Ledger compatible (to the best of my knowledge). Regardless, luckily for me I have screen captures of my wallet, it’s contents and the recovery phrase because that’s how I roll. I will retrieve my ADA eventually someday. Sadly, just not today. I will be setting up a VPN in the near future and updating this thread with my result.

Please if anyone would like to add to the technical aspects of this thread please do so. And by all means correct me if any of my presumptions are wrong or if anyone knows a viable workaround that actually works :slight_smile:


#2

I responded to your post in a previous thread, but i also am having a similar issue. I’ve had the “connecting to network” nightmare for about a month. Never had a any problems accessing my ADA until they released the update. I uninstalled daedalus and reinstalled about 5 times. no luck. I also tried VPN, and nothing. Like you, it was no small investment. I am actually really considering buying a new laptop just for daedalus. But even then whose to say the wallet would work? Not sure if thats a risk im willing to take…


#3

I had to delete DB - 1.0 folder or something like that in my AppData folder. This causes the wallet to have to re sync from the start and it’s been working ever since.


#4

Was that a fix for a “failed to sync issue” or a fix for the “Connect to network issue”

@RobMcvay the idea of not even a VPN working is kind of disturbing.


#5

Deleting DB-1.0 folder solved “Connecting to Network Issue” for some. First, try using a free VPN (like ProtonVPN it as a free plan), if it doesn’t work, try deleting the DB-1.0 folder from %appdata%/Daedalus folder.

Win:
Type %appdata% on the explorer’s address bar
Open Daedalus folder
Delete the content of DB-1.0

Mac:
On the Finder’s menu bar select Go
Click Go to Finder…
Type ~/Library/Application Support/Daedalus
Delete the content of the DB-1.0 folder


#6

Same thing solved failure to complete sync (stuck at XX.XX%) for me.


#7

Yes VPN did not work for me. I finally got my wallet up and running successfully last night after a whole month. What i did was uninstall, and delete the entire “Daedalus” folder under %appdata% and run CCLEANER PRO. CCleaner removed all registry entries affiliated with daedalus on my computer. i also did the disk clean up with CCleaner. I synced blocks from %0-%100, which took 16 hours. Then to actually restore my wallet, that took another 18 hours… its a process. Also, Be aware that when deleting the “daedalus” folder under %appdata, that can take hours and hours as well…hopefully this works for you as it did for me,


#8

I guess I will have to try this solution when I have that time to spend in front of my computer. I will update this thread with the results. Thank you for you inputs :slight_smile:


#9

Hey so when I submit a log for my deadalous I received a link in my email from bugs@iohk with some zen desk link…?


#10

#11

That’s nice I just wanted to make sure the email and link were legit and I should have recieved it along with the bugs ticket


#12

After a long story, a power outage and allot of hoopla… at the end of the day the long process of deleting the DB-1.0 folder (and updating the Cardano build) has given me back access to my wallet. Yay!

Since then I have discovered the Toast wallet for Ripple. What a dream. If only Daedalus just worked like this simple open source project does. But I digress… I have access to my ADA investment again.

What changed:
Welp, it would seem that with the DB-1.0 folder deleted and with the NEW build installed when Daedalus is “connecting to network” there is actual network activity of .1 MBs where as before there was none. Why? IDK. My suggestion to anyone who is having this problem is to do the same.

  1. Update to the newest build
  2. Delete your DB-1.0 folder
    Check network activity to see if your wallet is using .1MBs every 10 seconds or so then dropping back down to 0. If it is then your wallet is working as intended

In that order (give it allot of time and see what happens)
.