Daedalus 0.11.0 failing to start


#1

I installed the latest version of Daedalus on this Win 10 laptop as a manually downloaded upgrade yesterday.

The process was very quick and smooth, but after I clicked on the Start menu shortcut and OKed the UAC box nothing else happened. I checked for related processes in Task Manager but saw nothing.

I then restarted the laptop then started Daedalus not using a shortcut, ie by opening the program folder and double-clicking on the cardano-launcher.exe file. The UAC then Daedalus came up and worked just as it should.

However, when I tried to run it today, exactly the same thing happened as yesterday. It just occurred to me that the problem might be with the shortcut so I’ll try without it now.

OK, it worked. Something very strange going on here. There was a shortcut related problem after a previous update but that was because the arrangement had changed so that the shortcut now pointed at the wrong file, but that’s not the case this time.

Edit: just tried again using the shortcut, this time it worked. So it’s a head-scratcher.


#3

@vantuz-subhuman or someone else here might be able to answer that.

Edit: please remember this is really my topic! But this question is not about the main issue that we’re both experiencing (me intermittently) so maybe it doesn’t matter too much.


#4

It just happened again: I click on the Windows Start menu shortcut, the UAC dialog comes up and I ok it, then a command prompt window containing some text about certificates flashes up briefly, then that’s it.

In Task Manager I can find no processes related to Daedalus.

So I use File Explorer to enter the program folder, double-click on cardano-launcher.exe and it starts up properly, no problem (very fast in fact).

I close it down and check Task Manager again, nothing related seems to be left running.

Try the shortcut again and this time it works properly.

Very odd.


#5

Still waiting for tech support to get back to me. In the meantime, I’m wondering if I could reinstall 1.2 and try the update again?


#6

Don’t think there’s any point in reinstalling the old version. If you want to try again the most thorough method is to uninstall, then delete %APPDATA%\Daedalus (Win, sry don’t recall what you have – remember this is my thread!), then download and install again, and restore wallet. BUT of course make sure you have seed phrase first.


#7

Ok, I’ll wait a couple more days for tech support to get back to me. If not I will do the restore with seed phrase. Sorry I got on your thread again. Thanks!


#8

It happened again today, twice in a row for the first time IIRC. Started normally on the third attempt. In all cases I used the shortcut on the Win 10 Start menu and the UAC dialog appeared (of course I clicked yes on that), but on the first two tries the main program window failed to appear, and when I checked Task Manager no relevant processes were listed. Also, it seems that when the program fails to start, no log entries are made.

Am I the only one seeing this? :face_with_raised_eyebrow: