Daedalus 4.8.0

After upgrade, it hits 100% and then starts the loop over again from 0%, verifies to 100% and keeps repeating this cycle. It loads up to 100% pretty quickly, but just restarts again on a loop.
I have enabled the low spec option as the laptop I use for crypto is only 8gb RAM

8GB is almost certainly not enough memory. It might help if you add some swap space.

The other option is to use a light wallet.

My feedback, now that IO is listening… why are RTS options only made available when the Daedalus installer detects the system has a sub-par (<=8GB RAM) configuration?

Wouldn’t it be nice to have a tick-box in the Settings UI to specify -N so the node uses all the cores on my hexacore workstation, or maybe even -N4 invoked from a pull-down list to use 4 out of my 6 cores?

I’m grateful the RTS patch will help many users with dismal prospects for Daedalus, but a shame that only the needs of the performance limited were addressed without taking the opportunity to improve performance at the other end of the spectrum. :face_with_monocle:

It is supposed to be enough when using the RTS option, and in fact it was OK even before the 4.8.0 upgrade/RTS option, it just took hours to sync. Validation reaches 100% in about 45 minutes, so I am not sure that is the problem. The problem is that it immediately begins again from 0%.

Also, I do use Yoroi, but would rather use Daedalus if possible.

It is supposed to change the whole database structure in the 4.8.0 upgrade. 45 minutes is actually to short for that.

If you have the patience, perhaps try to delete the database folder and let it sync from the start?

(It took 23 hours for me and the database was not smaller and Daedalus not faster afterwards. A bit disappointing.)

I just uninstalled it, and am going to install it on another laptop, the one I use day-to-day, but also only 8gb RAM. See how it goes.

If you have windows try to increase the swap file

Cheeers,

Hello @Barney

There is actually another metric that is being shown when it hits 0% again. You can now see % of block being applied to the ledger. It doesn’t actually go down to 0%, just zooms in on the progress of applying a single block. You can also see that in the message change from verifying blockchain to:
DaeNew
So, you are still at 99.xx% just zooms in for this specific block(s). Also, that’s why the bar goes faster then full blockchain sync. :smiley:

Hello @COSDpool

It’s available in Help tab even if you have 16GB Ram. I’m running one Daedalus on 16GB laptop and this option is still shown under Help/ Using RTS flags.
DaeRTS

thanks, @Neo_Spank … if you’ve enabled this option, have you seen that you have any control over what RTS flags are used in the node’s environment? Mainly I’m hoping to control the -N RTS option somehow :nerd_face:

I didn’t enable it. I can just see it’s there. I have no need in my case. On that specific laptop (which is 7 year old) Daedalus starts in 3-5 minutes for me.

Thanks everyone for suggestions, it works on my other laptop. Still no idea what was going on with the other one, but hey ho. Taking hours to sync but that is to be expected.

No, it never moved on to the “applying block to ledger” screen, just reverted to same place. Now I have got it on a different laptop it did move on to this before starting to sync. So all good now, just deleted Daedalus from the 1st laptop!

the new update is not working a 100% for me ,but i see its faster and dont say the msg node not responding anymore to me but my sync dont move like a bullit train in tokyo its like​:turtle: went from 99.08% to 99.31% then loosing connection every 7min then i reload same loop again,i had a fever so can not sit for hours at computer and reload every connetion lose with the network,why is this lose realy realy dont have any clue left??? modem to computer its cabled so​:man_facepalming::man_shrugging::man_shrugging::man_shrugging::man_shrugging:

1 Like

My feedback, now that IO is listening

While I might be part of the official IOHK team, I do not work on Daedalus, the wallet or the ndoe.

:heart:CARDANO​:heart: SOME MAGIC HAS HAPPEND TODAY STARTED NODE AND BOOM IN ONE GO IT GOT SYNC TO A 100% TOOK 45MIN BUT THE WAIT WAS REWARDED GREAT TO HAVE THE WALLET FULLY LOADED WITH GUNPOWER.
THANKS CHARLES&IOHK&ADA TEAM GREAT WORK GUYS FOR THE LOW RAM MACHINES :heart::heart::heart::heart::heart::heart::heart::heart:

2 Likes

My daedalus is also validating on repeat but when it reaches a 100% it stops the node, the node crashes and than it automatically reloads and starts with the validating blocks again.

Does anyone know how to fix this?

I had the same experience for a short period after the upgrade, without the “block notification”. Now it works fine. Also less of an issue with the connection issue, which probably just was a memory or speed issue. 8GB is not too much, but works well with some patience as long as I run Daedalus every day or so! If I don’t the local integrity check takes a lot of time, up to several hours. Could it be the flags respond to screen-off and stop/pause the check?

FYI for anyone following this part of the question: I’ve just tried setting GHCRTS=-N for the desktop session environment in the hope we might be able to get Daedalus to use all our available processors (instead of effectively hard wired to a limit of 2):

http://downloads.haskell.org/~ghc/latest/docs/html/users_guide/runtime_control.html#rts-options-environment

No joy: RTS options here are ignored, as I mostly expected. I don’t need an explanation of why it doesn’t work (probably environment wiped when chrooting or running Nix) but we’ll eventually need control over RTS settings at the Daedalus cardano-node command line or with UI settings in Daedalus itself. :confused: