Daedalus and Trezor Model T public key mismatch

Hi dear, apologies for bothering. After seemingly successful pairing of Daedauls and Trezor Model T, shown public key on Daedalus and Trezor Model T screen mismatch when attempting to receive ADA. I have paired Trezor Model T with Adalite and there public key matches. Please advise whether I should warry and whether Trezor wallet should be deleted from Daedalus and re-paired? Thank you.

If on adalite.io is fine then u can try to delete the wallet from daedalus and pair again

Thank you. When pairing with Daedalus and when prompted to confirm public key, Trezor shown 64 digit long code. After that, wallet is paired and when attempting to receive ADA, Daedalus is showing much longer address while Trezor is showing same 64 digit/character-long key as when re-pairing it (same as after pairing Trezor for the first time). So, Daedalus and Trezor keys still do not match. Apologies for poor explanation and appreciate your help.

Can be byron vs shelley? Can u try to download yoroi chrome extension and try to pair the trezor on yoroi? Let’s see if this will work

Yoroi chrome extension works and keys match. Thank you. Does this mean I should give up on Daedalus pairing?

Hmmm, Try to uninstall and reinstall the daedalus but u can use yoroi or adalite.io till u will solve the daedalus issue

Yoroi seems to be the way for me as even after re-installing Daedalus same issue persists. Thank you for trying to help.

Sorry for bothering again. Can you please advise how to resolve the following: stake pool ID as shown on Yoroi does not match stake pool ID on my Trezor when authorizing delegation. Tried multiple pools on Yoroi and same issue remains. This and previously experienced mismatches on Trezor and Daedalus means that my Trezor is corrupted? Thank you.

Check the pool on adapools.org; each pool has 2 pool IDs … yoroi shows one and trezor the other one but should be the same pool

For example


Thank you. Tried Adalite.io and pool ID shown on Adalite does not match the pool ID shown on Trezor.

You didn’t understood… the ID from trezor check if match with the ID from adapols.org