Daedalus duplicated one of my wallets when i tried to rename the wallet

I renamed my wallet and, instead of having a new name, Daedalus created a new wallet with the new name BUT WITHOUT MY ADA IN IT. This new wallet has 0 ADA but can use my recovery phrase from the old wallet.

The old wallet still has all of my ADA but my recovery phrase does not work anymore. I verified this exact recovery phrase only 3 months ago. This is a big problem because the spending password is not working anymore either. I did not receive a new recovery phrase when the renaming created the new wallet. Before this happened I did update to the new version of the application 4.2.1 from version 4.0.5.

I tried moving my ADA to a new wallet (not the duplicated wallet), I could not do it because the spending password was not correct. So now my ADA is stuck in the old wallet which I have no recovery phrases to access. Do you have any idea why this happened? I still have my recovery phrases but I cannot access my ADA. This is madness.



Is this a simple wallet or do u have a trezor/ledger wallet?
It is a shelley wallet? If yes, do u have the24 seed words?


It is a shelley wallet. I have my 24 recovery phrases but I cannot access to the wallet which stores ADA after that wallet being duplicated. The newly duplicated wallet has 0 ADA but I can use my recovery phrases and passwords all that.

Ok, can u try to restore the wallet on adalite.io ?
Check if the wallet has balance there… if yes then delete all wallets from daedalus and restore the wallet again

I don’t dare to delete the wallets in daedulus yet except for the newly duplicated wallet. I tried deleting and restoring the newly duplicated but it still showed 0ADA. Let me try restoring on adalite

That’s why I asked you to try to restore the wallet on adalite.io first… if u see the balance there then u are safe to delete the wallets from daedalus


I tried and it showed 0 ADA instead of the balance in the old wallet. And I do not even know what keys or recovery phrases I should use to access the old one. Now I have 2 recovery phrases but 3 wallets (after being duplicated). This cannot be right.

Do u have ledger/trezor?

No i don’t have ledger/trezor

Ok, did u checked both seed words on adalite.io? Maybe u checked the seedwords for the new one

Hi I did check but the second seed words were created after the duplication happened. I was thinking I might move the fund to the new wallet and delete the previous 2 (old + duplicated), but found out the recovery phrases + password do not work on the original anymore, it only works on the newly duplicated wallet which has 0 ADA.

Can u share a picture with daedalus? Ofcourse hide the sensitive infos

So the ADA2021STA was the original one with the fund. After I tried to rename to MoonADA2021, it created the bottom wallet which now has the recovery phrases of the original but has 0 ADA.

The middle wallet is the last wallet I created after the duplication.

But if u delete the duplicate and rename back the original wallet… wondering if it will help

u have a message on the top right corner (the ring bell) what is’s saying?

It;s about stay safe from scammer and voting registration. So nothing about the issue

Do you mean that I now delete the duplicate, and rename the duplicate as ADA2021STA after it being restored?

So ADA2021STA it’s the original wallet name, and MoonADA2021 is the duplicated one with no ADA
Try to delete MoonADA2021 wallet and restart the daedalus


I already tried delete the wallet, restart daedalus and restore the wallet again. but apparently it does not work. It still appears as 3 different wallets, and the original ADA2021STA has no recovery phrases which work. Screenshot 2021-08-15 at 23.16.40

Now I try to delete and restore the duplicated wallet, renamed it ADA2021STA but I don’t see it merging the original and the duplicated.

Hmm, then u must have another 24 seed words for the original wallet

anyway u should contact IOHK team, they should check…
I know that if u already have a wallet u can’t add the same wallet same time; the message the wallet already exist should appear

The wallet is not synced

Screenshot 2021-08-15 at 23.16.40

U must wait till the wallet will be 100% synced