Daedalus stuck at Replaying Ledger at 99.45%

My wallet does not seem to be replaying the ledger fully. Daedalus does not show itself connecting to mainnet, nor the node responding or syncing. The node is crashing after awhile. Does anyone know how to fix? Should I delete anything?

This is a known issue and is currently being worked on. I will post again when there is a fix available. ETA is a day or two.

Deleted the wallet and chain, and am resyncing. This is kind of time sensitive. Should I be able to get the wallet working with that, or am I going to need to install a lite wallet to make my transaction?

Deleting the wallet and chain will not help. There is a bug in the node software that comes with Daedalus.

If you need immediate access to your funds I would suggest one of the following:

  • Loading your seedphrase into a lite wallet like adalite.
  • If you are pretty highly computer literate you can replace the installed cardano-node version 1.35.4 with 1.35.7 and everything should just work (I did this and it worked. I use Linux).
1 Like

Ended up using Yoroi. I needed to resync the wallet anyways. Would have taken a few hours.

1 Like

You can resync with the Daedalus you have, but it will not get past the block height at which it was crashing before.

There will be a new release in the next couple of days, or you can do what I described above.

The new version (5.3.1) has been released to Daedalus - Downloads .

Glad you got it working.