Editing stake pledge amount - metadata not showing up in Daedalus

Hello Community,

Does anyone know how to amend the pledge amount for a stake pool after its already been registered? I made the mistake of adding an extra zero when registering the pledge amount. Also, the metadata (ie pool name, ticker, etc) is not showing up in Daedalus yet. It has been about 6 hours since we registered.

Thanks so much,

Stag Digital

You must have done something wrong usually it will take about 15min max. I’ve been there.

1 Like

Good to know it shouldn’t take too long. Will review further. Do you know how to revise the amount pledged? I also made an error with the amount I wanted to pledge.

Yeah sure, Please check this link.
start from “Generate Stake pool registration certificate” skip the " Generate delegation certificate pledge"
Then “Submit the pool certificate and delegation certificate to the blockchain”
OK, here’s the tricky part.
When build the transaction, “Do not” deduct the pool deposit again. Just your UTxO balance - Fee
then sign the transaction and submit. Done check within 15 minutes your pledge should be overwrite.
Good luck.

This worked, we were able to get our correct pledge amount up, thank you.

We still can not get our ticker and Pool name to show up on pooltool… We hosted our .json on github, but now it won’t let us update our pool cert. Keep getting error:

--out-file pool.cert

Invalid argument `/home/********/cold-keys/node.vkey’

I’m really sorry, I can help you if you host your .json in github, because I host my .json in my website. good luck

Location of hosting .json shouldn’t matter as long as cert points to it correctly?

We’ll explore this today.

Thanks for your help so far, appreciate it.

I was having an issue very similar. When I first registered I made a mistake when copying the URL to the metaData.json. After several frustrating days and attempts the only thing that worked was renaming the metaData.json and hosting in a different location. Once I did that and re submitted everything showed up almost instantly in Pooltool, Adapools and Daedalus.

1 Like

From what I learn you must point it directly to the .json file for example https://xxx.com/mymeta.json Something like that. Hope that Help.

1 Like

Tried this but we are still getting the error:

--out-file pool.cert

Invalid argument `/home/********/cold-keys/node.vkey’

For some reason the commend cannot find our node.vkey even though it is in the file. Will keep conducting trial and error.

Tried your idea but still having an issue with the pool.cert - for some reason the command is nor recognizing the command:

–out-file pool.cert

Invalid argument `/home/********/cold-keys/node.vkey’

Are you following the instruction from the link that I gave?
I think cardano cli cannot fine the cold.vkey that’s why it gave error msg
I mean if you do, is that should be

--cold-verification-key-file cold.vkey

and please don’t use this ’ when you type the /home/**/cold-keys/node.vkey

look at the single quotes around the file path string - they should look like this:


the forum doesn’t do a great job displaying quotes as they would appear in a text editor, but the outer lying quotes should be straight (not curved or angled)

1 Like