Error - Incorrect Ledger Device on Yoroi

When attempting to make a transaction in my Yoroi wallet using my Ledger nano X, I am getting the error message:

“Incorrect device detected. Expected device xxxx but got device xxxx. Please plug in the correct device”

I have one ledger… Im using the correct device… Any idea what the issue could be here ?

Thanks!

Hello,

Yes, probably u changed the ledger device and yoroi has ur old keys associated; uninstall yoroi/ install again and try again to connect ur ledger

Cheers,

2 Likes

This worked! Thank you Alexd1985!

2 Likes

Hi, I have same issue but I am using both for the same account, a Ledger Nano X and a Ledger Nano S.

When I set up my Yoroi-Wallet, I used the Nano S. Later I’ve bought a Nano X. I restored the new Nano X from the same recovery phrase as my Nano S, also I don’t set an additional passphrase.

Now, when I try to send ADA from Yoroi with my Nano X, I always get the message:
“Incorrect device detected. Expected device xxxx but got device xxxx. Please plug in the correct device”.
If I do the same with the Nano S, it works fine.

Then I imported my Wallet with the Nano X also to Yoroi and then it works.
But if I try to send here with the Nano S, I get the same message like before.

From the Apps I use the latest release on both Nano’s and for Yoroi.
I tried with Chrome and Brave browser. Both get the same issue. And I don’t use any VPN connection.

So, for each type of a Nano device I have to import the Wallet, even it is the same?

Also the Support from Emurgo still have no ideas but they say, that I should be able to access my wallet with both of my Nano’s, but in just one connection to Yoroi.

I hope, someone can help, thanks

Yes, becauae yoroi stored the keys for ur old/latest hw wallet… if u want to use 2 hw wallet same time with same browser u will need 2 chrome/brave accounts… one account for each hw wallet…
or u can use one hw wallet on brave and another one on chrome; Or u can use adalite.io

Cheers,

1 Like

Hi Alexd1985,
ok, so my thoughts was right and I did nothing wrong when I imported my Nano S and later also my Nano X into the same Yoroi.
Thank you so much :pray:
I will send this also to my Emurgo supporter, that she can close my case.
Have a nice day!

1 Like

I had the same issue with incorrect device message. I had staked ADA with rewards. Tried to withdraw rewards but got the incorrect device message. I uninstalled the Yoroi on Brave and re-installed it, then connect to my Nano S, but now on the Yoroi my balance is zero now! Please help! :scream:

Do u see anything to transactions history?
Do u have more ledger hardware devices?
Do u used PIN or passphrases when u created the wallet?

I have 2 Nano S. Didn’t have any PIN or paraphrase for Yoroi because it connected to Nano S directly. Didn’t have any transaction history during the uninstall install process. I assume not transaction history from withdraw attempts because Yoroi couldn’t connect to Nono S. I thought I used the same Nano S as when I setup Yoroi. Maybe I am wrong. Should I install ADA app on the other Nano S? But I would have to uninstall app for other crypto and I am afraid I will lose those crypto as well.

If helps, I updated the Ledger Live recently, and also have the address of Yoroi I sned to from Binance when I first setup Yoroi (it looks like in the same format as current Yoroi address). Thank you.

Same format but if u check the address from binance on yoroi to receive section… is there?
can happens sometimes to be an issue with yoroi (sync issues) so if u find the address from binance to receive section on yoroi you can try to restore the ledger on adalite.io

no address or transaction from binance on the current Yoroi wallet. The receiving address on the reinstalled Yoroi (current one) is different from the one I found on binance transaction history. I connected the Nano S with ADAlite but still 0 balance and no transaction history. However, I searched ADAex.org with the address I have from Binance and able to see the balance still staked. Anyway to reconnect to that address from binance with Yoroi or ADAlite?

Could be possible to find your ADA on the other ledger… or are u 100% sure that the ADA are secured by ledger and u didn’t sent to a standard yoroi wallet?

I delegated through Yoroi delegation list. The staking pool name is Pilot. I just follow the instructions from Yoroi and approved on Nano S. I assumed I didn’t sent to any address outside the Pilot pool address from the delegation tab in Yoroi. I dont do any transaction other than staking and fund transfer from binance.

If u remember that u acknowledged the transaction with ledger then should be fine… u should check the other ledger… if this ledger it’s empty u can try to restore using the seed words from the other ledger device

Thank you so much. I reset my second ledger to factory setting and restore with first Nano S recovery phrases. Connect with ADAlite and now I can see my balance. Again, thank you for your help. Much appreciated.

1 Like