Ethos BIP39 private key tool not working! Cardano stuck

I don’t know the first thing about crypto, but my husband decided to buy some cardano kept in an ethos wallet which he now can’t get out… We tried the advice and instructions posted on the forum here to use the BIP39 tool to extract a private key, but the ‘derive addresses’ button doesn’t appear to be a valid link (either online or offline). Can anyone help!?

@rdlrt You were the last poster, wonder if you’ve got any advice?? :crossed_fingers:

Hi!

Do you have the 24 word recovery phrase?
btw, just linking the post here

Yes, we input the 24 words but the actual button to then generate the private key doesn’t appear to then do anything. It’s like there is no action or hyperlink and it’s just text, so after inputting words there’s no way to then generate the private key. I’ve tried pressing enter clicking the button and right click to see if there’s any other options. Tried several browsers too, and the offline version!

Hi!

And have you tried Yoroi chrome extension - and there recover Byron wallet? in the original post someone else suggested this recovery - but I dont know why have not tried this…
Yoroi is an official wallet along with Daedalus…

They say

Ethos uses technology from BIP32, BIP39 and BIP44 to help you better manage your crypto assets. These allow you to create a nested, hierarchical structure from your seed using what are called derivation paths. Derivation paths derive a private/public key pair from a seed which is encoded as the 24 word mnemonic SmartKey that you create when you first use a SmartWallet.

Derivation paths are structured as follows: m/[purpose]/[coin type]/[account]/[ETHOS WALLET INDEX]/[change]/[ETHOS ADDRESS INDEX]

This is good news, because it would mean that you are not limited to their tooling.

The Cardano situation is somewhat awkward with respect to these standards. AFAIK, it uses a modified ed25519 variant of the elliptic curve algorithm. In practice it means, that you can take your 24 words from Daedalus, Youroi, ADALite and use them with the other two (i.e. these wallets are compatible with each other).

The Ledger HW wallet uses a different algorithm and you would see a set of empty addreses if you enter the 24-words from above. For Trezor I’m not sure, but I suspect it is compatible with Ledger. Both of them have been around long enough to probably use the original BTC algorithm (just guessing).

For Ethos, we don’t know, but it is unlikely that they do something else all together. First, try the obvious and enter your 24-words in ADALite.io and see what happens. If you see empty accounts, Ethos in not compatible with those Cardano wallets mentioned above.

Next, if you have a Ledger, try the same with that, or ask a friend that you really trust to do this for you. Note, you do not give a third party your 24-words unless you absolutely trust them.

If that fails, we need to use the Ethos tooling. Is the ethos-source.github.io website really trustworthy? If you think it is, you should be able to see your first batch of addresses with associated funds. What do you see when you select Cardano and enter your 24-words?

If that works, we’ll have to use their wallet-recovery-cli.
I can likely help you with that as well, if needed.

1 Like

No not tried this, I was trying to get to the bottom of why the ethos tool doesn’t appear to be generating anything. Thanks for the suggestion!

So we went straight down the github route as per the post linked by the guy above - it seemed to be the most commonly posted solution to the issue. However, when we select cardano and enter the 24 words nothing happens, all I see is the words I entered and no way to generate anything in order to use the wallet recovery tool.

I tried the tool like this …

Do you have a private key that is 192 characters long?

1 Like

No I’m guessing that’s what I should be able to generate using my 24 words and the ethos tool but when I put in the words it doesn’t do anything?

Have you tried the ethos tool yourself in order to generate the private key? This is the step I need help on as I’m aware I can’t use the wallet recovery CLI without it.

So I put in my 24 words (obvs not in the screenshot) - should the tool just autogenerate, or do I need to press the ‘derive addresses’ button? The issue I’m having is that big orange button isn’t clickable and I don’t see another way to proceed?

I really appreciate the help :slight_smile: :slightly_smiling_face:

I don’t have a valid Ethos mnemonic and if I enter random words from the dictionary the button does not activate. I also looked at the sources and I see that the button is generally disabled. It may get enabled by certain actions on the page, but I don’t see how. The JavaScript that is downloaded with the page does not seem to do that - at least not AFAICS.

You said something about an offline version of this? In parallel, please get in touch with Ethos support and tell them that their BIP39 tool might be broken. If if there is some sort of plausibility checking, it would be reasonable to see some feedback to that regard.

Later in the sources, there is this hidden message …

which you also don’t see, right?

Perhaps they have a command line tool as well.

Thank you for investigating. I did a bit of interrogation and also determined it said disabled but in all honesty I don’t understand code at all so presumed I could well have misread another vital bit of information. I don’t get any errors or trigger any actions whatsoever. I did reach out to the Ethos support last night to query so I’ll follow up there now that I know it isn’t just me thinking it might be broken!

Appreciate you bearing with me, this crypto stuff is not my bag :joy:

Let’s try another path …

#1 Download the zip file from here

image

#2 Unpack the downloaded file and open index.html in a text editor
#3 In line 232 remove the disabled="disabled" attribute

#4 Open the hacked index.html in your browser (i.e. Chrome). The button should now be active
#5 Enter your 24 words. Actually type them and don’t just paste - perhaps it wants to see keystrokes
#6 Hit the button

Doing this I see …

Somebody, already created an issue last summer. Even if this works for you, it is probably best you create an issue too (if only for the benefit of others)

Look at this … they indeed do some checking

Hi rabk1991,

My guess is that your 24 word mnemonic phrase was written down slightly incorrectly, e.g. a typo such as changing “say” to “way”, and as a result the Ethos tool is detecting a checksum error and not letting you proceed. Hopefully you’ll be able to find the typo and use their tool to migrate your address. You can check the BIP39 English word list to make sure all of the words you entered are on the list, and if you find one that isn’t, try replacing it with a similar looking word.

I’ve run into this problem before and have written a tool for correcting small mistakes in mnemonic phrases. Using this tool I was able to restore the accounts of 2 of my friends who had similar issues, although not Ethos wallet related. If all else fails and you don’t have any luck recovering your account, please feel free to contact me for more info.

Thanks, you were indeed right…I’ve managed to generate the private key but now having no luck with the wallet recovery tool!