Fail to update "my wallet adress"

#1

Hi. After sending ADA from my Daedelus wallet to Yoroi the Dadeleus wallet generated a new address for the ADA that was left but failed to update “my wallet address” that had the old address. The same thing happens when I generate a new address manually in Daedelus twice. My ADA is still there as it is always in the latest generated address, but my wallet address is empty since it is not where the ADA is currently transferred. So total during 3 new generated address “my wallet address” shows the old address. While a minor bug since my understanding is a wallet consist of all created adresses and my ADA is very safe I still feel I should mention it here. I do not want to disclose my addresses or logs for anonymity reasons currently. (Do not want to be a potential target of criminals.) Also when I look in cardano explorer on the transactions they are all correct so I believe there is nothing wrong with the transactions and more a problem with updating “my wallet address” correctly in Deadelus.

#2

Hi Eystein, does your Daedalus wallet show the correct total balance at the top?

And, did Yoroi show the correct balance after the send? I think I recall someone giving a similar description on tech support.

~Rick

#3

Yes both show correct amount. Only “my wallet address” is wrong.

1 Like
#4

Ah, I wonder if this is the same thing that drove me crazy about how UTXO works. I had to do some experiments to understand what I was looking at. Like this… the total wallet balance would be 10 Ada but when I look up any 1 address the balance might be 1 or 0 or 6 or 2 or some random number. So is this like what you are seeing?

Daedalus total: 10 Ada

But if I look up any of the addresses in Daedalus I see…

Crazy Address #1 = 3 Ada
Crazy Address #2 = 0 Ada
Crazy Address #3 = 0 Ada
Crazy Address #4 = 1 Ada
Crazy Address #5 = 5 Ada
Crazy Address #6 = 1 Ada

But I still get a balance of 10. Am I understanding this correctly?

#5

One address lets call it #8 the newest has all the ADA left (0.83) while Yoroi wallet has the transferred amount. My wallet address shows address #5. Address #5 has zero ADA as almost all was transferred in Yoroi transfer and the rest to the newly generated #6 address so address #6 had the 0.83 ADA left. Since my wallet address incorrectly used address #5 I tried twice generating new address #7 then #8. ADA correctly transferred from #6 to #7 then #8. Problem is my wallet address still use address #5. And yes wallet balance has been correct at all times. Problem is only using wrong address as my wallet address.

1 Like
#6

UTxO change addresses aren’t displayed in he list of receiving addresses in Daedalus. “It’s not a bug, it’s a feature!” :smiley:

1 Like
#7

Ok, I was planning on updating my Daedalus and Yoroi videos and currently working on a Trezor video. But I think I can to run a really cool video showing how perplexing this can be with UTXO.

I have some ideas on how to explain this visually. Can I give you a shout out in the video @Eystein_Hansen?

(now I just need to motivate myself to do it, need more coffee)

1 Like
#8

I am not sure I follow you. I have all the correct receiving addresses. My problem is that “my wallet address” the one that is at the top that you can copy - is using the wrong address. It is using an old. The list of addresses in the bottom is correct they are all there. And no matter if I generate a new one it keeps using the old address. If that is a correct behavior that seems odd. I think in my other wallet this has not happened. I have for example one wallet where I have done a sending and it still uses the latest address under “my wallet address” unlike in this transfer between Daedelus and Yoroi. But if there is something I am misunderstanding here I am all ears to understanding it better.

#9

First lets make sure we are talking about the same thing. And I think it is a great idea especially now with Trezor and Ledger.

#10

I’m going to play around with Daedalus and see if the sending address changes when it is not expected to.

#11

This part is the part using the old address
image

#12

My answer isn’t correct, I thought of something else.

#13

Bumping this as I have the same problem now with Yoroi. I think there is something wrong with the code in Cardano Explorer and not with Yoroi or Daedalus. I created a new Yoroi ledger wallet and transfered from my old Yoroi adress most of the ADA. Transfers all went fine and in Yoroi everything shows up just fine. However if I check my old Yoroi wallet adress in Cardano Explorer it shows up with 0 ada while it should have a residue of 0.122808 ADA. I had planned to keep 500 ADA in this wallet as a spending wallet without need for ledger but I did not feel safe once I saw Cardano Explorer wrongly updated this.

#14

The description in this particular post does not look like an issue or a bug. If Wallet 1, address A had 500 ADA and you sent 499 ADA to Wallet 2,address x, the remaining 0.83 ADA left in Wallet 1 would have moved to address B, not in address A. The description of behaviour earlier sounds different, but its not very clear (I got an impression that you were talking about ‘unused’ address there.

#15

I do not think so because the old yoroi wallet has two adresses generated and in Cardano Explorer neither one of the adresses show the correct amount. Both show 0 ADA. In Yoroi it shows up correct. The new Yoroi ledger wallet shows up correct in both Yoroi and Cardano Explorer.

#16

And yes the older Daedelus issue I am not sure. In that case I could still find the correct amount in Cardano Exploret but not in the latest adress generated. In this case with Yoroi I cant find the correct amount in any of the adresses in Cardano Explorer. My line of thinking is that since it is in Cardano Explorer the problem shows it must be the problem and not Yoroi nor Daedelus as both of these have the total amount still there.

#17

You do not see the change address in Yoroi (which is where confusion comes from?). Thus, addresses you are copying from Yoroi show 0 balances in Cardano Explorer (which is correct on explorer part).

#18

Let me get this straight the two recieving adresses I have in the old Yoroi wallet is not the only adresses with my transfers? So after I use yoroi for a transfer I can no longer use cardano explorer to check on my ADA amount in the old wallet?

I will really appreciate it if someone explained to me as I cant understand why Cardano explorer would show 0 ADA in both Yoroi addresses on my old wallet when that old wallet still has 0.12 ada left and it and shows 0.12 ada left in Yoroi. Either my understanding is wrong or Cardano Explorer code is wrong.