Funds LOST! Created a Yoroi wallet using Trezor T

So I go to the Yoroi website. Download the extension. Click on “Connect to a hardware wallet”. Select the Trezor T. Select Shelley-Era wallet. I am then asked for a passphrase. I enter the passphrase (Obviously my Trezor T is connected). Confirm the passphrase on Trezor T. It now opens up an ADA wallet. Everything was fine up until now. I transfer 337 ADA to this wallet with the address :


Now, I wasn’t asked or given ANY keys or recovery keys/phrase by Yoroi. I am now wondering how can I log out of the Yoroi wallet because there is no clear option to log out or sign out of the wallet. I scroll down and find “Remove Wallet” under the wallet setting. Which ALSO says that “Your funds are safe even if you remove this wallet”. I have now removed this wallet and disconnected my Trezor T.

After a while I go back to the Yoroi wallet and I am asked for the same information so I put it on, log into my Trezor and Yoroi wallet, only this time I am suddenly given a new wallet address with 0 balance. I can’t understand how I can go back to my account which holds 337 ADA (Check above). Does anyone know how I can recover my account?

1 Like

You funds are likely not lost at all. Your Trezor holds the private key for your account. To double check, you could use to have a look at your address.

1 Like


I connected my Trezor T to the wallet. The balance is 0. What do I do now?

1 Like

Are we talking about this Tx here

From what I understood, you authorized this Tx and now you expect to see those 337 ADA with your account. Is this correct?


But u are sure that the wallet deleted from yoroi was a trezor one?
What if it was a simple wallet? Do u ever created a simple yoroi wallet and if yes it is possible to have a 15 seed words ?


Hi @riptrick ,

If you use hardware wallet (Trezor/Ledger), you will not get 24 words seed phrase, as your hardware will take care about that.

I don’t understand why you need to “Remove Wallet” though. Just let it be there.

Everytime you want to do transaction, you just need to connect your Trezor to approve the transaction.

@tomdx & @Alexd1985 will help you here. Thank you guys.

1 Like

Yes! This is it. Help!


I clearly remember it was a hardware wallet. There were NO keys or passphrase given to me.

And… how did u tried to restore the wallet?

I haven’t tried restoring the Trezor T yet. Is that a solution?

Please don’t restore your Trezor T. Kindly check this similar problem like yours below. You just need to restore your Yoroi Wallet using Trezor T. See how the other people did it. Thanks

Not the trezor wallet, the yoroi wallet how did u tried to restore?

1 Like

Can you explain it to me. I tried reading the post but it only confused me further. Please help I am panicking.

If ADALite is not showing your funds either, are you sure you sent your ADA to an address that your Trezor controls? Is it possible that you sent those funds to somebody else (by accident)?

1 Like


I could not have sent it to somebody else. When I first connected my Trezor T to the Yoroi Wallet. it brought me to a Yoroi wallet. I then tried staking/delegating it but I wasn’t sure of how it works since I am new to this world so I left it at that. However, when I tried removing the wallet by selecting “remove wallet” from the Yoroi wallet settings and connecting it back, it gave me a new address altogether. Almost like a new wallet.

Now when I try to connect my Trezor T it takes me to a Yoroi wallet with 0 balance.
Also, when I try connecting my wallet with a passphrase (which i need to confirm on my Trezor T) it takes me to another wallet with again, 0 balance.

Have I lost access to my ADA?

One more thing we could try …

Go to the ADALite Accounts page. If you don’t see it there, your funds have been sent to an address that your Trezor does not control.

1 Like

Are you sure you are using the right passphrase when accessing the wallet?

Everytime you access a wallet from Trezor you can use a passphrase to derive a certain key from your “main” private key, which is stored in hardware. This makes it possible to have “infinite” different wallets, just use another passphrase and a different key gets derived.

This passphrase can be empty. Or anything you want. Just know that everything you enter leads to a valid wallet! Learn more here:


I’m convinced it’s all got to do with the passphrase as you mentioned. I have only used 1 passphrase ever. Tried it again, still takes me to a wallet with 0 balance. Tried multiple passphrases. Was taken to new wallets.

Still no access to my first wallet which holds 377.76 ADA
I really think I have lost them. :slightly_frowning_face:


Checked ADALite. 0 Balance :slightly_frowning_face:

That sucks :slightly_frowning_face: Maybe you had a typo in the initial passphrase? :confused: