Guide Raspberry Pi 4 HTN Setup [Pi Pool]

Hey!
Because I didn’t find any guide to how to setup the HTN on Raspberry Pi, I decided to create one by my own. I have a Raspberry Pi 4 8 GB and the HTN works perfectly on it. It’s always in sync and I successfully minted blocks. I just upgraded to 1.14.0 and it’s working as well. Let’s see when I get my first block there.
So the guide is made for the new 1.14.0 node:

Let me know, if something didn’t work.

My Pool:
Pi Pool
Pool Id: fa278a3295ddaf540b4bba061fd8e08aa7f96bc98fa55b1b8bead314

4 Likes

Hi, thanks for that. The stake pool cannot be done on Pi at the moment? it can be done in second phase or i didnt get it right? thanks

It can be done. The guide shows you how to. Simply it doesn’t work if you follow the “official” guides from IOHK because they currently just focus on x86 machines. But with a little workaround it works on the Pi as well.

1 Like

im keen to do it so ill give it a go now. other than Shelly Node are you using this Pi for something else?What`s the size of your sdcard and class?Also, are you using any firewall like ufw ?Or VPN?Please drop any advice you can.Thank you.

No I just bought the Pi for this task. I’m using an SSD with 256GB.
No I’m not having a Firewall right now. Could it help against DDos?

let me get this straight. are you running the pool from the SD and not from SD?are you booting from SSD? Internet gateway and firewall definitely helps against DDoS!

While this guide has some significance I doubt you would produce too many blocks or win slot battles on a PI but plx post your stats.

Using external SSD is a minimum this blockchain does constant RW operations on the filesystem so if you put this on an MMC card first it will be slow as hell second it will destroy the card very fast.

I would consider setting up a Docker for this and just put some pool setup scripts in it so everyone can skip the formalities and do a docker pull and go from there.

According pool tool, your pool produced absolutely NOTHING so far:
Pi Pool fa278a3295ddaf54…

0 4.0% 90.0k 0.000% 0.0 0

It’s because node 1.140 just came out yesterday and it’s a new chain. Also if you do not have the Pool vKey added you don’t see the blocks. Look at pools on page 1. There are a lot with 0 blocks. Doesn’t make sense. It’s just not represented correctly.

I minted 12/12 blocks in not even 2 days without problems. So the Pi has no problem at all. This was on node version 1.13.0

Hello
I am interested to create a stacking pool on a RPi 4. If i would follow your guide, what would i need to do, onece shelly gies live?
Do you have any tips for a newby in the Cardano space?

I can’t tell you, because Shelley hasn’t launched yet. But it’s good practice to setup a stakepool on the testnet.

What come out yesterday?
Maybe I missed something but I running this since about 2 weeks.

Nirvana: it will be the same process so it’s good that you practice it. The genesis will be different and these configs:

35 wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/ff-topology.json
36 wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/ff-genesis.json
37 wget https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/ff-config.json

But mainnet will be essentially the same 1 block producing and 2 relay nodes.

Hi guys,

I’m new in this space but keen to put a node up and running myself. I’ve also read some things about the Rock pi to use as a node, but the info about this one is a bit fragmented to me…

My question to you; Does this manual work for the Rock Pi as well?

Thanks in advance!

New genesis file and node version 1.14.0

Hey, if you get ubuntu 20.04 64 bit running on it, you can definitely use the guide.

Allright thanks!

Thanks for the answers.
I will try to set up the Pi on the Testnet.