How to resolve Daedalus connectivity problems

Hi all,

if you experience connectivity issues with Daedalus there is a work around by adding working peers to the config file. I wrote a short tutorial how to solve the problems step by step:

If you are not sure yet who to delegate with, check out our Germany based stake pools Hermes (HRMS) and Hermina (HRMA).

Please let me know if there is anything unclear with the guide,

Cheers Wunderbaer

5 Likes

Worked for me, thanks a lot @wunderbaer :grin:

1 Like

happy to hear that! :slight_smile:

Didn’t stay in sync for long though… :frowning: Might go through the procedure again later…

1 Like

try restarting it before changing peers again

1 Like

That did it, I was able to change my delegation, thanks again! :grinning:

1 Like

Saved me time! Much Thanks!! :+1:

1 Like

Excellent post! Fixed my Daedalus wallet connection problems - Thanks!

1 Like

I tried that and am still not able to reconnect. Been 2 days now :frowning:

First try simply failed to connect. Second try is stuck at 7%.

Third try gets to 99% and then stalls.

Fourth try finally got it synced!

2 Likes

Great post… Didn’t work though. I made sure the JSON was formatted correctly. Tried it with some of the IP’s and ID’s, other times with all the listings… Daedalus just kept bouncing between ‘Connecting’ and ‘Disconnecting’… I gotta’ say; I know this is a ‘testnet’, but the way IOHK just leaves us hanging with this bunk ‘wallet’ issue speaks volumes… It’s kinda’ like they don’t give a sh… I don’t hear anything official from IOHK. Wasn’t a fix supposed to be released on the 29th? SOS…

This is not actually a wallet issue. The connectivity issues are with the underlying Rust node.

The reason this has not been resolved sooner is that engineers (who had worked really hard to deliver this thing) were on much deserved leave.

My understanding is that this is being worked on.

1 Like

Good to know. Thanks!

HI!

The jormungandr-config.yaml is a YAML file. The JSON format is but a proper subset of YAML format. But jormungandr uses the YAML format parser to read the file, so it’s perfectly safe to reformat the whole content of a file as a proper YAML:

rest:
  listen: 127.0.0.1:3100
log:
  - format: plain
    level: info
    output: stderr
p2p:
  topics_of_interest:
    blocks: normal
    messages: low
  trusted_peers:
    - address: "/ip4/3.124.116.145/tcp/3000"
      id: 99cb10f53185fbef110472d45a36082905ee12df8a049b74
    - address: "/ip4/52.28.91.178/tcp/3000"
      id: 23b3ca09c644fe8098f64c24d75d9f79c8e058642e63a28c
    - address: "/ip4/13.112.181.42/tcp/3000"
      id: 52762c49a84699d43c96fdfe6de18079fb2512077d6aa5bc
    - address: "/ip4/52.8.15.52/tcp/3000"
      id: 18bf81a75e5b15a49b843a66f61602e14d4261fb5595b5f5
    - address: "/ip4/3.125.183.71/tcp/3000"
      id: 9d15a9e2f1336c7acda8ced34e929f697dc24ea0910c3e67
    - address: "/ip4/3.125.31.84/tcp/3000"
      id: 8f9ff09765684199b351d520defac463b1282a63d3cc99ca
    - address: "/ip4/18.184.35.137/tcp/3000"
      id: 06aa98b0ab6589f464d08911717115ef354161f0dc727858
    - address: "/ip4/18.182.115.51/tcp/3000"
      id: 8529e334a39a5b6033b698be2040b1089d8f67e0102e2575
    - address: "/ip4/3.115.154.161/tcp/3000"
      id: 35bead7d45b3b8bda5e74aa12126d871069e7617b7f4fe62

In this form, inserting peers from the https://adapools.org/peers page will be as easy as copy+paste the fragment below trusted_peers.

2 Likes

I’ve made a gist with the converted file: https://gist.github.com/royaltm/4ab9735a891797fbd0d52879470b135f

Link to the file: https://gist.githubusercontent.com/royaltm/4ab9735a891797fbd0d52879470b135f/raw/ac5af5687428b7d4ab15eaa9e52cffec0775c4b2/jormungandr-config.yaml

This, would be a Royal improvement!

3 Likes

On top of this (while waiting for new Daedalus - Rewards version release), you can get the latest version of Jormungandr from:

Search and download the correct version for your OS (https://superuser.com/questions/173788/how-to-find-the-architecture-of-os-installed). In my case, it was windows-msvc:

Unzip it and replace the next files in the installation folder of “Daedalus - Rewards v1” (for Windows: “C:\Program Files\Daedalus - Rewards v1”):

  • jcli.exe
  • jormungandr.exe

Don’t forget to make a backup of the installation folder first, in case it doesn’t work.

3 Likes

Adapools made it easier:

4 Likes

very nice! :slight_smile:

We updated the tutorial as well and added the information how to update the node + wallet backend! Plus you can find another peer at the very bottom that might not be as overloaded as the adapools ones (at least for now) :wink:

Nice Rob :+1:

1 Like

I tried this to fix just a sync issue and now my Daedalus ITN does not work at all. No connections at all.

I’m on a Mac running the latest Catalina. The first problem I had was permissions on the file to change it. Then I had an ownership issue. Next I had the same problems right up the file system to all enclosing items. Changed all those. Now it does not work at all.

This is too complicated and too time consuming it is certainly not beta quality software.

1 Like