Still haven't been able to connect to incentivized testnet

I have not been able to get connected to the incentivized testnet wtih Daedulus wallet.

I am using a Mac, with Mojave 10.14.1. I have tried numerous times to install, uninstall, re-install the incentivized testnet wallet, with all versions since the first release, including the most current one. I delete all associated files and start fresh each time. I opened two tickets on this now with IOHK support (zen desk) and nothing yet. Mainnet Daedalus works fine for me. I use VPN to bypass any potential ISP issues. I have tried using a different internet connection to make sure it is not something about my router. I have turned off my firewall.

Not once have I seen the incentivized testnet wallet connect to anything. It never gets beyond the “Connecting to network…” message. The “Cardano node is not responding” stays grey and the “Cardano node is not syncing” stays grey also. It never once has come close to connecting to a node from what I can tell.

Yes, I have tried to “RESTART CARDANO NODE” using button in Daedalus Diagnostics. Many many times.

I have noticed with the Mainnet wallet there is one process that runs over one single IPv4 port. With the ITN1 wallet there are 2 processes, cardano-w and jormungan. These two processes are listening at the same port. Then jormungan is also listening at second port. Is this what I would expect?

When I open the console (Developer Tools) I see the following:

renderer.js:34 [2020-01-12T03:15:21.141Z] [daedalus.*itn_rewards_v1*:error:ipcRenderer] {
  "msg": "AdaApi::getNetworkInfo error",
  "data": {
    "error": {
      "code": "ECONNRESET",
      "errno": "ECONNRESET",
      "syscall": "read"

Anyone that has any clues to help solve this one? Any ideas I can try?

1 Like

I would suggest you try both with and without the VPN.

When I run the ITN Daedalus wallet it often does not connect the first time. If it doesn’t connect within 5 minutes I try again. It usually connects within 3 or 4 retries.

Its also worth having a look at the graph at the top . It the number of errors (in red) is high and the number of blocks (in black) is low, it is going to be more difficult to connect to the ITN than with the error count is low and the block count is high.

You linked to a general Mainnet support page. Is there something in there I should know about that could help? I have searched the online help articles from IOHK and tried their suggestions. Perhaps there is something specific you can point to?

Thanks! Chad

Yes, I have tried both ways (with and without VPN). I have tried connecting, and waiting, and connecting, and waiting, and connecting…

I will have a look at the adapool resource as you have suggested. Thanks!!

I suggest you fill out a support ticket. The link is accessible from inside the Daedalus ITN wallet.

it is very difficult to connect to’s the network problem,it will be solved through time I suppose.
for now what I do is open the software and leave it for half an hour,if it connected then lucky me,if not,then very likely the software has given up connecting to network,you can check the log file to see the information "Waited too long for Jörmungandr to become available. Giving up!"then close the software and reopen it and wait for it,until it is quite frustrating but for now we have to endure.


Yes, I have filled out two support tickets on this, have one open now. They inevitably ask me to do all the things my ticket states I have already tried, as if they don’t actually read the notes before replying. I am hoping someone in the community reads this and recognizes that they already solved a similar problem, and says how.

That is interesting, thanks for the further insight into the real state of the network.

This is what I do, exactly and it works, not every single time, this works and I also recommend trying it.

Same here. Oddly, it seems to help if I open the DAEDALUS DIAGNOSTICS page and leave it open while the wallet tries to connect.

1 Like

Been suffering the same symptoms … wallet mostly unusable, other than a few brief connections early on. Have given up - now simply waiting for the update.

I had pretty much the same experience as yourself, I tried everything you did then one day I just left it running… trying to connect for about 30-40 minutes and to my surprise it connected. It takes between 3-10 minutes now. Good luck :+1:

1 Like

I am disappointed for you, generally from what I have seen here on the forum is if someone continues to be persistant they will eventually get it open. at this time the wallet needs support from the jorg network to verify transactions etc. and it has not been very stable as pool operators are stress testing it, I read through my logs to understand what was happening when I could not get it to connect and when I saw other problems and I realized that the problem was coming from the nodes my ITN wallet was trying to connect to - the network was basically refusing my connection request, might have been for latency reasons or whatever (my isp is not the best) I kept restartin, over and over again, I deleted the wallets, removed all trace from my computer - redownloaded, did it all again lol! and finally I it found a peer to connect to. I did all that after my wallet balance was a bit glitchy and I had gone through all the steps before - what a process- throughout the process I leared to clean up my computer for better operation of the ITN wallet - I erase my browsing history and make sure I have minimal programs running in the background - I probably ought to defragment more often come to think of it but just cleaning up gives the wallet better access to the Ram and I connect quicker.

1 Like

It’s the same here for me…Connected right up All was well,Joined a pool all was well…Then boom zero balance shown and have done a full wipe several times.It won’t connect most of the time and when I let it sit overnight it gets stuck on 47%.Pretty much going to have to sit on my hands until things iron out at this point.

Sad to say, I am taking comfort in that it is not just me having issues, at least I know it is not necessarily something wrong with my setup. The kicker is that I have not been able to stake all my hard earned ADA because I have never been able to connect to the network.

Same troubles here with Mac and Catalina. The testnet wallet worked for a short while. But I haven’t been able to connect now for a couple of weeks and have tried the same recommended solutions. So, unable to switch stake pools despite knowing my current stake pool is saturated.

So glad this is happening on the testnet and not mainnet. Just hope it get fixed soon so I can connect and stake my ADA. Started accumulating in 2017, now I am finally feeling impatient to stake after much delay. I am more concerned that it gets done right than getting to stake soon though. The world will eventually want/need a programmable decentralized crypto that can work well at a worldwide scale.

Not sure if you’re already aware but you can still stake through Yoroi without being dependent on Daedalus.

Also, just a thought, if you’re on a laptop, possibly try connecting via a friend’s or someone you trusts ISP provider and try with or without VPN at that point just to eliminate any potential issues with your own ISP. Hopefully that helps too.

1 Like

I have suspected my ISP was an issue, mainnet only works with VPN, but it does work well and the testnet does not connect at all, VPN or not. I have tried other internet connections to no avail.

Yes, I am going to venture into the Yoroi world today, just so I can finally get staked. Thanks for bring that up, I have considered it but was focused on Daedalus and kept putting it off.