How to send ADA from my stake pool to my Daedalus wallet

Hello,

I am trying to withdrawal ADA from my stake pool by sending it to my Daedalus wallet. I followed all the steps to create the transaction, sign and submit. I did not get an error but when querying the UTXO, the balance is still there. I followed steps found here 3. Create a simple transaction — cardano-node Documentation 1.0.0 documentation

Is there a way to check logs to see if the transaction failed, I did not receive an error and it seemed to go trough as expected.

1 Like

Actually I dont know what is the transaction id to able check it on the cardano explorer…
but it is a good sign if the ADA is arrived to your Daedalus wallet…

Yeah, that hasn’t happened yet. Something might have gone wrong.

interesting - if there is no error during submission then for me it was success all the time… try again…

I suggest using ATADA scripts. Very easy to use

Hello,

Check STEP 18.9 Send a simple transaction example

https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node#18-9-send-a-simple-transaction-example

Cheers,

Thanks @Alexd1985

I am still receiving this error. It says valueNotConserved. I am trying to send all the ADA in my stake pool as I have retired the pool and will no longer run it. I made sure to substract the fee from the balance. The script on CoinCashew has it echoed back so I’m sure that the arithmetic’s are correct. Is there any other fee or factor that I am not accounting for?
utxoFailed

Hmmm, it’s saying bad value… did u calculated well?

please keep 1 ADA on your spending addr.

1 Like

@laplasz I tried keeping 1 ADA in the spending addr but still getting the same error.

I think it’s right. The only thing is that the fee is calculated via the script. I am substracting the fee - balance = sendingAmount. I tried leaving 1000000 lovelace like @laplasz mentioned but still getting the same error.

The node is working right? It is synced?
Also can u try with only 10 ADA first?

interesting… so since you followed 3. Create a simple transaction — cardano-node Documentation 1.0.0 documentation
could you please share the command you executed what is described in 3.7. Build the transaction
(try to select the text on the console use CTRL+SHIFT+C to copy and CTRL+V to insert it here)

Thank you both @Alexd1985 @laplasz I was finally able to complete the transaction. There were two mistakes I was making. Number 1 was that my relay was not on and it was the only way that my block-producer could get out to the blockchain. Number 2 the CoinCashew scripts had an extra tx-out for change. Since I was taking out all the money on the address, there was no need for that variable. We did it, thanks!!!

2 Likes

don’t forget about 500 ADA which u should receive back in 1-2 epochs for now

Cheers,

1 Like