How to verify recovery phrase? Issues with multiple wallets

Hey what’s up fellow ADA enthusiasts!

I created a Daedalus wallet at the end of 17’ Byron wallet. I haven’t logged on to the wallet since like early 2018. Just wanted a safe place to hold the ADA.

I got a new PC and downloaded Daedalus and have had a terrible time getting it to sync to the block chain. Specs are fine on my machine. Daedalus just gets stuck in a node crashing loop. I currently have a ticked open with IOHK.

So I tried then restoring my ADA with yoroi. Everything seemed to be going good but I received and error that said “error while restoring block chain addresses” does anyone know what that means?

Ive been told to verify the recovery phrase, but I can’t quite figure out how to do that.
Since my Daedalus wallet is tweaking and getting that error on yoroi. I’m 99.9999% sure the recovery phrase is correct. All the words populated in the window when entering it in.

Anyone run into a similar issue?

Thanks for taking the time to help!


You have an alternative to daedalus and yoroi… which is

U can try to restore ur wallet there (be sure to access not a clone site), or u can wait till IOHK will provide u an answer/WA to solve your daedalus issue.


I think there is many people having this problem, me included. I’ve went through everything I could (thanks for all the help Alexd1985). But nothing has worked. Was told by tech support I would have to wait for the import option to become available. So don’t delete your old version or its files. Honestly, not sure what to do if that doesn’t work. Super frustrating…good luck

Same problem here. Hopefully support can fix it somehow.

Please contact the IOHK support team. if u are sure the seed words is 100% valid
you can check if the words are correct by comparing with words from this list:

All my words are on the list. I will contact support again. Thank you!

1 Like