HTN Adrestia wallet balance

Good evening. I’ve been working on my prototype to get a Faucet Game running, where I have a wallet that acts like a faucet, but pays out as players play. All has been going well until tonight; is 1.14.0 killing me?

Basically, I run Adrestia Cardano-Wallet and then expose it to my game via a server. I created a new Faucet wallet in the HTN Daedalus and transferred 20k fADA. The balance there is all good. However, when I call Cardano-Wallet, it allows me to recover the wallet through the API, but reports a zero balance; with the 20k back in the original sending wallet.

Have I configured something wrongly or am I being blocked by the new 1.14 roll out? I’m wondering if the transaction hasn’t propogated correctly?

I’m sure this all worked at the weekend, but has now blocked my development; which is annoying as I was trying to get a Proof of Demo up by the end of this weekend. Especially as using fADA is less risky to me than using real.

Any thoughts would be really appreciated

Carl (Crazy Career Games).

Not much to go by conclusively :slight_smile:

If you’ve restored a wallet, it will take a while to actually sync the balance - but I assume you already knew this. You say you created walelet via HTN daedalus , and then calling cardano-wallet:

  • do you mean wallet was already restored and up to tip?
  • are both Daedalus and cardano-wallet connecting to same node? If not, and if you’re connecting to different nodes, is the node associated with cardano-wallet up to tip?

Thanks for your response. Since 1.14, all has been good. I think it was due to the switch over.