Issues creating Yoroi wallet on Android

I unexpectedly had to turn the laptop holding my Daedalus wallet in for urgent repairs (defective battery about to pop…). I am reasonably sure the technicians will not go snooping around on it, and even if they do they won’t have my spending password. But why take a chance, right? :slight_smile:

Since I currently don’t have access to a computer where I can install Daedalus (my backup laptop is way too old) but I do have an up to date Samsung tablet (Android 9), I decide to try moving my funds over to a Yoroi wallet.

Here’s where the fun begins.

First I tried the Android app. When creating a new wallet, I am asked to input the 15-word seed phrase in the correct order. No matter how many times I retry and doublecheck (and restarting from scratch three times) this invariably returns an “incorrect passphrase” error when I input the 14th word. Every. Single. Time.

So then I install the Chrome extension but can’t get it to show. Am I correct in that this only works on a desktop version of Chrome? Or am I missing something?

I then try the less hobbled Kiwi Browser. This time everything works, the Yoroi icon shows where it’s supposed to, the passphrase verification is successful, but then I’m asked to check two disclaimers and click “confirm”. The confirm button does nothing…

At this point I’m rather exasperated. It shouldn’t be this hard. Am I doing something wrong? Any advice would be greatly appreciated…

I can still try the Chrome extension on a work computer tomorrow. Failing that I’ll just have to hope for the best, I guess…

I’ve never used Daedalus, but I’ve had no issues with my seed word on Yoroi for Android or the Chrome browser running on Mac OS and Chrome OS.

I do remember seeing a Daedalus to Yoroi button in the top right hand corner of the Yoroi Wallet. Maybe you can start there to see if their is a wallet conversion process?

I’m sure others will chime in with better advice here too.

Thanks for the input, @Adam_Parish . Yes, Yoroi can “import” funds from a Daedalus wallet, but you do need to create an empty Yoroi wallet first. And that’s where I ran into difficulties every time.

Anwyay, I tried it on my work laptop this morning. Installed Yoroi Chrome extension, created a new wallet, and transfered all ADA from the old Daedalus wallet. Nice and smooth. So all my funds are secure again, for now.

I’m still curious why I couldn’t get it to work at first though. Has anyone else experienced the issues I described above?

Is the Android app not yet reliable? Does Yoroi not work 100% on Kiwi? Google didn’t seem to know… And I may goof once or twice, but a whole evening of continuous goofing seems …unlikely :slight_smile:

1 Like

Sorry, just bad luck! We accidentally introduced this bug and we’ve already fixed it. Sorry you were affected.

1 Like

I still wonder why wallet issues keep resurfacing after 2 years of Cardano development, no matter how small they seem to be.Many times it is mistake on user side but still …

You’re obviously not a software developer. Any major update is likely to introduce new bugs as well as fix old ones. The idea that software under development should reach a state of perfection and then stay there is sheer fantasy.

Oh come on , than one should not refine product to “state of perfection” with other people money. You are not developing tetris but something which may be used in banking therefore standards for perfection are high, 2 years were more than enough to develop robust wallet.

It’s easy to say, I know, but it’s really, genuinely, not that simple. The main algorithms are formally proven correct, that is not possible with the rest of the software. It’s fairly safe to say that no product that is continuously under significant development is entirely robust. It is easy to snipe from the sidelines, when you have some appreciation of what is actually happening things look different.


I agree, you have a point here.


No worries @SebastienGllmt , these things happen :slight_smile:

I assume you’re referring to the Android app, and not the chrome extension. I’ll give the app another try then.