Just venting Daedalus Rewards doesn't work...yes, yes, yes testnet, but it doesn't work

LS, Same here re the help desk. After repeated emails from them regarding issues with the first version of the testnet wallet today I get an email telling me about version 2.2 which of course we now already know doesn’t work on some (mine) Macs.

Is it too hard hard to keep a simple header notice on the delegation page and perhaps a “Known Issues” sentence or two?

I got it to work. It took quite a long time to get connected with 2.1.0 but when I did I just restored rewards wallets and they were good to go. However, when I restored the balance wallet it ruined everything. So, restore your rewards wallet(s), don’t try to restore your balance wallet and should be fine.

2.2.0 was just released and they said it might take 20 minutes to load. For me it loads in 5 or so, and rewards wallets were still there from when I had installed 2.1.0. I haven’t tried restoring my balance wallet though… too worried I’ll mess it up again.

RE: my last post, just read your comment “I have a 12 word recovery phrase not 15 word” that may well be the problem. As I said in my last post, the 12 word recovery phrases weren’t working to restore the balance wallet, only rewards wallets were working for me. I haven’t tested with the new version of testnet daedalus though. Perhaps purge/uninstall the 2.1.0 version and then install the new one, give it as shot and update us on whether it worked.

Note: I have also found the support response to be junk. Sent a request/comment about similar issues with my system logs, got a response to do what I had said in my message that I had already done. Then didn’t hear anything back when I responded.

I just installed 2.2.0 over the 2.1.0 version.

It connected within minutes, and both balance and reward wallet (neither of which I had bothered to properly restore after the 2.1.0 update somehow lost them) are also back.

Procrastination paid off this time, I guess. :partying_face:


When was 2.20 released? And do I have the right sequence of updates?


If so the latest - 2.2.0 - still does not not get past Macs gatekeeper.

You are correct. 2.0.1 was followed by 2.1.0 then 2.2.0.

And version 2.2.0 was just released on Monday. Can’t help with the gatekeeper problem. Sorry.

1 Like

Gonna have to try restoring my balance wallet now. Thanks for the update.

Thanks. Yes apparently 2.1.0 was not properly notarized and can’t be opened with the newer Mac OS. This was supposed to be addressed with this release but I still can’t open it.

On top of that I can’t even open a support ticket without the wallet.

Try emailing: support at iohk dot zendesk dot com
–sorry will only let me put 2 URLs/Links per post.

That said, based on comments on the forum and my own experience they aren’t super helpful, but give it a shot. Likely more luck searching reddit and the forum for support from other users.

Here’s a crazy idea though. If its not working in Mac and it’s working in Linux, you can install a virtual machine and run Linux in a window in your Mac.

Download virtual box: https://www.virtualbox.org/wiki/Downloads
Install a linux distribution like Ubuntu, Mint, or Pop_OS (a couple I have found quite user friendly and with good performance. All are pretty user friendly, but I think Pop will be very familiar if you have a Mac:
PopOS: https://system76.com/pop

Install as a virtual system on your Mac, don’t have a handy link to explain this, but should be able to Google if you can’t figure it out on your own. Then download and install Daedalus Linux.
Download Daedalus at the staking cardano website.

Open terminal in your linux virtual machine and copy/paste$$$$
bash ~/Downloads/daedalus-2.2.0-ITN1-cardano-wallet-2020.2.17-itn_rewards_v1-x86_64-linux-10873.bin

Restore wallets as you normally would.

Maybe this will get around the Mac issue… a bit of work, but could be a fun time. Maybe. Let me know how it goes if you try it.

1 Like

Thanks Caffeine.

Support responds but without any help offered. I get the same standard " he test net may not run as smoothly as you expect " reply. This forum is the only reason I have any clue about what is going on which shouldn’t be the case.

Re linux, yoroi I have no confidence that something else won’t get screwed up in the process and with the lack of support from IOHK the testnet would be done before the problem was fixed.

yeah maybe worth it to wait for another update then. Had similar issues with support. Good luck.

Thank you very much. Hopefully they’re available on weekends.

So far support just says here follow this protocol. But when the protocol doesn’t work you end up having to repeat yourself ten times that your repeated the protocol and their additional assistance is useless. Most frustrating 3 weeks of my entire life. I have no idea how this is supposed to become a mainstream or trillion dollar market with stuff like this happening to many people.

Yes, this seems like the typical support experience. However, what is the update on what you have done to find a solution? Have you installed Daedealus 2.2.0? This seems to have solved most problems for folks, except for those using a Mac system. Details like OS and what actions you have taken can help the community help you solve the issue you are having.

1 Like

I had the same experience. For the past two months, Daedalus was working once for like an hour for me. Enough to start delegating, but was not able to connect ever since (also tried multiple workarounds).

I switched to Yoroi and everything is fine now. I seriously hope that mainnet Daedalus will not be this crappy as the testnet one.

That’s the whole point of the testnet – so they know how to design the mainnet so it’s exactly as crappy as this one… :rofl: :rofl: :rofl:

1 Like

Yeah, it truly is shocking how awfully developed the Daedalus ITN Wallet is. It’s broken, it just simply does not work (at least for nearly EVERYONE attempting to use it based on what people have been posting here, reddit, twitter, youtube comment sections, telegram, discord, the list goes on and on and on and on…). The only logical explanation I can think of as to why the Daedalus ITN Wallet has been so horrendously developed is because they’re trying to push people to use Yoroi, if that’s not the case, then yikes, truly the epitome of developer incompetence.

I took the plunge and restored one wallets through yoroi. worked great. thanks.
Is there a way to support multiple wallets from the chrome extension. I can’t seem to find out how.

1 Like

Well, I’m assuming they didn’t call it a “testnet” just for shits and giggles… :wink:

And it’s no surprise the Yoroi light wallet has less issues than its full node brother — it places a lot less demands on your system…

Always keep in mind that Daedalus ITN is not a release product. It was made for the Cardano devs’ benefit, not for ours. (Well, for ours too, ultimately. But I trust you catch my drift :slight_smile: )

Us early adopters are just volunteering as test subjects, in return for being able to earn some extra ADA.

I also find it frustrating at times, but everyone who is participating in the ITN made a choice to do so (hopefully after doing their due diligence). And when it gets too hot, we can always walk back out of the kitchen…