My ISP is blocking daedalus network connection

Everytime, daedalus attempts a network connection, it never connects. I’ve checked firewalls, open all necessary ports, etc. Tried using Windows and Unbuntu . But daedalus can’t connect. Maybe, Cardano, ( foundation, or IOHK) can start building partnerships with some of the oversized ISP. After all in the US, Net Neutrality gives them the right to microscopically throttle bandwidth for specific connections.

1 Like

Have you tried doing a packet capture?

Anyone know if there is a host we can telnet to in order to troubleshoot connectivity issues?

Moved to appropriate location, CTS.

Can you try using a VPN? Or a different ISP, for instance a mobile network, or take your computer to a neighbour/friend/relative’s house, just to confirm that’s the issue?

1 Like

My entire zip code, everyone within 8 miles radius, have the same provider. I could use a VPN but I am bringing up this issue for the less technical daedalus users.

Haven’t try sniffing packets yet. I probably could use Ethereal. But our every day ADA users wouldn’t want to do all that just to use a wallet. I could use Yori but I am just playing around with cardano components. I am sure it’s my ISP blocking the connection. Someone recommended a vpn. I will try it.

Can you tether your machine to your mobile phone?

Mobile is fine because it’s a different ISP, wireless carrier

Yep, looks your ISP is blocking Kademlia as it is used for P2P file sharing.

Here are the network ports used by Daedalus.
DNS - TCP/UDP port 53
Kademlia - TCP port 3000
NTP - UDP port 123
SSL - TCP port 443

I don’t think IOHK is going to be able to do much about this in the short term.
You could try ExpressVPN but I’m not sure what security protocols they support or their log retention policy.

Do you have a compelling reason to use Daedalus over Yoroi? It’s just as secure.


Thanks for your input.

Not really. I just wanted to test it out because I plan on doing some consulting work on the Cardano ecosystem.