Please, have been trying to restore back my yoroi account on my mobile phone

Have been trying to recover back my yoroi account on my mobile phone.
But each time I write out the 15 word phrase the system keeps telling me to write out a valid recovery phrase.

Am very sure the 15 word recovery phrase are correct. Cause I wrote them down when I created the account.

Can someone please help me. I really need to recover the wallet

Try the seed words on, if u will see the balance = 0 then u should search for a new seed words… perhaps u are using a wrong one

I just did,but it’s still not working.!
The unlock button didn’t change so I could click on it.

Sounds like the words are not the right words or the right order. Did you write them down on paper? Maybe a misspelling?

Yes I wrote them out on a paper.

But am show the are in well arranged. Have also check the spelling. They are all rightly spelt

Hmm, perhaps u restored the daedalus into yoroi? Check for another 24 seed words… or maybe u are trying with the seed words for byron…

Strange. Does it recover into Yoroi on a browser? you mentioned you’re doing this on your phone?

Haven’t tried it on a browser yet.
Only on my phone

It’s possible somehow the phone isn’t working where it may work elsewhere. Try installing Yoroi on a reasonably secure browser, one that has no other extensions added and is on a system you’re sure is free of malware. Is your phone capitalizing any of the characters of the words by chance? Like an auto-correct maybe in your keyboard is altering the words you type in the app? That would probably cause this type of error.


im having the same issue i have recovered my account fine on pc but for my phone after i put in the 15 words the bottom restore button doesnt highlight at all have repeated putting in the words a dozen times

while im happy i got some version of my wallet restored im not home on my pc all day i really need it on my phone - have contacted support but trying to find the solution myself as well

try to unistall the app and reinstall

then open yoroi → add wallet (shelley wallet) → restore

This is what i already done twice - the button to restore just wont highlight to click once i put the 15 words in

Have since logged onto pc and reatored there and the 15 words worked so i think its the app via mobile thats the problem

1 Like

then indeed, it is possible to be an issue with the app

I believe there is a problem with the android app, Works fine on the chrome extension browser when restored but when I tried it on my new phone (samsung s21), restore button is disabled.

Is there any ways to see my recovery phrase on my android yoroi wallet. I lost the paper that written the phrase

nope, but if u have control of the funds, create another wallet , bkp the seed words, and move the funds


Many thans. Yes. I have full control on my android wallet.

1 Like

i have same issue from Google Chrome extension on my macbook. i put the 15 words and restore button is disabled.

i was able to access from my Iphone. but not sure what is going on with Chrome extension

Have you tried ccvault?